summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm50
1 files changed, 18 insertions, 32 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 0d051438e3..8971c11479 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -245,10 +245,7 @@ and very fast.")
(chdir "libvisual")
#t)))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("libintl" ,intltool)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal intltool libtool pkg-config))
(inputs
(list sdl))
(native-search-paths
@@ -300,20 +297,20 @@ applications that want audio visualisation and audio visualisation plugins.")
(chdir "libvisual-plugins")
#t)))))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("gettext" ,gettext-minimal)
- ("libintl" ,intltool)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list bison
+ flex
+ gettext-minimal
+ intltool
+ libtool
+ pkg-config))
(inputs
- `(("alsa-lib" ,alsa-lib)
- ("esound" ,esound)
- ("librsvg" ,librsvg)
- ("gtk+" ,gtk+-2)
- ("jack" ,jack-2)
- ("libx11" ,libx11)
- ("libxext" ,libxext)))
+ (list alsa-lib
+ esound
+ librsvg
+ gtk+-2
+ jack-2
+ libx11
+ libxext))
(propagated-inputs
(list libvisual))
(synopsis "Audio visualisation library")
@@ -477,7 +474,6 @@ the GStreamer multimedia framework.")
(build-system meson-build-system)
(arguments
(list #:disallowed-references (list python)
- #:meson meson-0.63
#:phases
#~(modify-phases %standard-phases
#$@%common-gstreamer-phases
@@ -593,7 +589,6 @@ This package provides the core library and elements.")
xorg-server-for-tests))
(arguments
(list
- #:meson meson-0.63
#:phases
#~(modify-phases %standard-phases
#$@%common-gstreamer-phases
@@ -659,7 +654,6 @@ for the GStreamer multimedia library.")
(build-system meson-build-system)
(arguments
(list
- #:meson meson-0.63
#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
#~(modify-phases %standard-phases
@@ -782,7 +776,6 @@ model to base your own plug-in on, here it is.")
(build-system meson-build-system)
(arguments
(list
- #:meson meson-0.63
#:configure-flags #~(list "-Dsctp-internal-usrsctp=disabled")
#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
@@ -961,8 +954,7 @@ par compared to the rest.")
(base32 "1486x08bwasq6l7kc75nph5az61siq9mbgkgpw4kf1mxn16z8c4g"))))
(build-system meson-build-system)
(arguments
- (list #:meson meson-0.63
- #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ (list #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
#~(modify-phases %standard-phases
#$@%common-gstreamer-phases
@@ -1019,13 +1011,9 @@ think twice about shipping them.")
(sha256
(base32 "1zfg7giwampmjxkqr5pqy66vck42b0akmwby661brwz8iy3zkapw"))))
(build-system meson-build-system)
- (arguments (list #:meson meson-0.63))
- (native-inputs
- (list perl pkg-config python-wrapper ruby))
- (inputs
- (list ffmpeg))
- (propagated-inputs
- (list gstreamer gst-plugins-base))
+ (native-inputs (list perl pkg-config python-wrapper ruby))
+ (inputs (list ffmpeg))
+ (propagated-inputs (list gstreamer gst-plugins-base))
(synopsis "GStreamer plugins and helper libraries")
(description "Gst-Libav contains a GStreamer plugin for using the encoders,
decoders, muxers, and demuxers provided by FFmpeg.")
@@ -1047,7 +1035,6 @@ decoders, muxers, and demuxers provided by FFmpeg.")
(build-system meson-build-system)
(arguments
(list
- #:meson meson-0.63
#:tests? #f ; FIXME: 16/23 failing tests.
#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases #~(modify-phases %standard-phases
@@ -1116,7 +1103,6 @@ binary, but none of the actual plugins.")))
(build-system meson-build-system)
(arguments
(list
- #:meson meson-0.63
#:modules `((guix build meson-build-system)
(guix build utils)
((guix build python-build-system) #:prefix python:))