summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e9e46a30b2..8395fba094 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1038,6 +1038,28 @@ patterns as per the HaRP extension as well as HSX-style embedded XML syntax.")
@code{haskell-src-exts} trees.")
(license license:bsd-3)))
+(define-public ghc-refact
+ (package
+ (name "ghc-refact")
+ (version "0.3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "refact/refact-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0v0zxcx29b8jxs2kgy9csykqcp8kzhdvyylw2xfwmj4pfxr2kl0a"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/refact")
+ (synopsis "Specify refactorings to perform with apply-refact")
+ (description
+ "This library provides a datatype which can be interpreted by
+@code{apply-refact}. It exists as a seperate library so that applications can
+specify refactorings without depending on GHC.")
+ (license license:bsd-3)))
+
(define-public hlint
(package
(name "hlint")