summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm66
1 files changed, 24 insertions, 42 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index ea510142f8..181d24acd6 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages fonts)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
@@ -565,28 +566,26 @@ extracting icontainer icon files.")
(define-public libtiff
(package
(name "libtiff")
- (version "4.3.0")
+ (version "4.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.osgeo.org/libtiff/tiff-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "1j3snghqjbhwmnm5vz3dr1zm68dj15mgbx1wqld7vkl7n2nfaihf"))))
+ "1h8xrcpbyf9id2hw2ms0cmpgx0li8gladjzj82ycgk28018pnc29"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.8 MiB of HTML documentation
(arguments
- ;; Instead of using --docdir, this package has its own --with-docdir.
- `(#:configure-flags
- (list (string-append "--with-docdir="
- (assoc-ref %outputs "doc")
- "/share/doc/"
- ,name "-" ,(package-version this-package))
- "--disable-static")))
- (inputs `(("zlib" ,zlib)
- ("libjpeg" ,libjpeg-turbo)))
+ (list #:configure-flags
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ #~(list (string-append "--with-docdir=" #$output:doc "/share/doc/"
+ #$name "-" #$(package-version this-package))
+ "--disable-static")))
+ (inputs
+ (list libjpeg-turbo xz zlib))
(synopsis "Library for handling TIFF files")
(description
"Libtiff provides support for the Tag Image File Format (TIFF), a format
@@ -595,6 +594,8 @@ Included are a library, libtiff, for reading and writing TIFF and a small
collection of tools for doing simple manipulations of TIFF images.")
(license (license:non-copyleft "file://COPYRIGHT"
"See COPYRIGHT in the distribution."))
+ (properties
+ '((upstream-name . "tiff")))
(home-page "http://www.simplesystems.org/libtiff/")))
(define-public leptonica
@@ -669,26 +670,12 @@ arithmetic ops.")
(base32
"0dwa24kjqyg9hmm40fh048sdxfpnasz43l2rm8wlkw1qbdlpd517"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-static")
- #:phases (modify-phases %standard-phases
- (add-before 'bootstrap 'force-bootstrap
- (lambda _
- ;; XXX: jbig2dec 0.18 was released with
- ;; a broken configure script, so we
- ;; recreate the build system here.
- ;; Remove the autoconf inputs below
- ;; when deleting this code.
- (delete-file "configure")
- (delete-file "autogen.sh")
- #t)))))
+ (arguments '(#:configure-flags '("--disable-static")))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("python" ,python-minimal-wrapper))) ;for tests
+ (list python-minimal-wrapper)) ;for tests
(synopsis "Decoder of the JBIG2 image compression format")
(description
- "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
+ "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
monochrome) images at moderately high resolution, and in particular scanned
paper documents. In this domain it is very efficient, offering compression
ratios on the order of 100:1.
@@ -778,17 +765,17 @@ images of initially unknown height.")
(define-public openjpeg-data
(package
(name "openjpeg-data")
- (version "2020.11.30")
+ (version "2021.09.26")
(source
(origin
(method git-fetch)
(uri
(git-reference
(url "https://github.com/uclouvain/openjpeg-data")
- (commit "cd724fb1f93e6af41ebc68c4904f4bf2a4cd1e60")))
+ (commit "1f3d093030f9a0b43353ec6b48500f65786ff57a")))
(file-name (git-file-name name version))
(sha256
- (base32 "1q2swh4g9r9haqs075fyk42aclqcs9q51lqqzfb57lisszminpwm"))))
+ (base32 "13jpdaqk7mngk0xw6xbh9zgipip6n25spvqd97hwpfna1zyh8lzh"))))
(build-system copy-build-system)
(synopsis "Test files for OpenJPEG")
(description "OpenJPEG-Data contains all files required to run the openjpeg
@@ -800,7 +787,7 @@ test suite, including conformance tests (following Rec. ITU-T T.803 | ISO/IEC
(define-public openjpeg
(package
(name "openjpeg")
- (version "2.4.0")
+ (version "2.5.0")
(source
(origin
(method git-fetch)
@@ -809,7 +796,7 @@ test suite, including conformance tests (following Rec. ITU-T T.803 | ISO/IEC
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "143dvy5g6v6129lzvl0r8mrgva2fppkn0zl099qmi9yi9l9h7yyf"))))
+ (base32 "0xvcxlzqlylnjsyl1j64d7rgzv68ihm4qy6fpdrix3xzbqb3fjpz"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -1640,14 +1627,14 @@ is hereby granted."))))
(define-public libjpeg-turbo
(package
(name "libjpeg-turbo")
- (version "2.0.5")
+ (version "2.1.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libjpeg-turbo/"
version "/libjpeg-turbo-" version ".tar.gz"))
(sha256
(base32
- "0pbv6pc97kbj7ib31qcwi7lnmm9xg5y3b11aasmkhfjvf7rgdy0n"))))
+ "1l3n9xgkh85ny1pvy78ps0xnlfmps4h7glvcwlzh6aw30c4k2ys6"))))
(build-system cmake-build-system)
(native-inputs
(list nasm))
@@ -1677,12 +1664,7 @@ is hereby granted."))))
((string-prefix? "riscv64" target)
`("-DCMAKE_SYSTEM_PROCESSOR=riscv64"))
(else '()))
- '())))
- ,@(if (%current-target-system)
- '()
- ;; Use a special "bootstrap" CMake for the native build to work
- ;; around a circular dependency between CMake and this package.
- `(#:cmake ,cmake-bootstrap))))
+ '())))))
(home-page "https://libjpeg-turbo.org/")
(synopsis "SIMD-accelerated JPEG image handling library")
(description "libjpeg-turbo is a JPEG image codec that accelerates baseline