summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm176
1 files changed, 157 insertions, 19 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6e9ebc49f4..24b4980efd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -426,8 +426,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
It has been modified to remove all non-free binary blobs.")
(license license:gpl2)))
-(define %linux-libre-version "5.1.2")
-(define %linux-libre-hash "1v4i5lf95zjp3gvswhla9jz7yqkl0k13blf6y2z0229xh05627jb")
+(define %linux-libre-version "5.1.3")
+(define %linux-libre-hash "07y1hl1r4na7yd9k113q0vij54hw9m32kcg7wli2y2f5xxdzb6dx")
(define %linux-libre-5.1-patches
(list %boot-logo-patch
@@ -440,8 +440,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-5.1-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.19-version "4.19.43")
-(define %linux-libre-4.19-hash "15lx2igfqazn6v0nzs0y1ii6a0mmwqi9dnivs36a9r2f17l8p6p7")
+(define %linux-libre-4.19-version "4.19.44")
+(define %linux-libre-4.19-hash "1shxns3b5dm2hq6h59y3pc1ks4x1hbxqcchzncxz53gf2xqyz95i")
(define %linux-libre-4.19-patches
(list %boot-logo-patch
@@ -454,8 +454,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-4.19-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.119")
-(define %linux-libre-4.14-hash "18bi9cjmy1cw0kjwckcbiaj1iw8sx2isz3vpdgb3si9zhzfcjnz2")
+(define %linux-libre-4.14-version "4.14.120")
+(define %linux-libre-4.14-hash "0ll8m46cdbfrp6nvjcjm8w4alm75rg95k2lcdj72gfjnn8dfsnv1")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -464,14 +464,14 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.176"
- "0v5rhb1nd9h4ssm0jxf3vspcm954pp7vkmz2k99p0yhw45i3aj6x"
+ (make-linux-libre "4.9.177"
+ "1zzv863qzzzri4xdcqr84pgbfafvfi6wylbxv6qz139fx638z9bd"
'("x86_64-linux" "i686-linux")
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.179"
- "025jl50sgi3bxj8hxlihqyfshmfphrg6z3cfi043qwkc8sbdy3af"
+ (make-linux-libre "4.4.180"
+ "157kfs4slii86q9yrspvqdynpiv6rff80hrrn569v6h4nkc4b7ag"
'("x86_64-linux" "i686-linux")
#:configuration-file kernel-config
#:extra-options
@@ -559,6 +559,80 @@ between the CDemu userspace daemon and linux kernel.")
;;;
+;;; Linux kernel modules.
+;;;
+
+(define-public acpi-call-linux-module
+ (package
+ (name "acpi-call-linux-module")
+ (version "3.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/teleshoes/acpi_call.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04mbv4lasm3vv1j4ndxhnz4hvp5wg8f5fc9q6qxv0nhvwjynmsl3"))))
+ (build-system linux-module-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-for-linux-4.12
+ (lambda _
+ (substitute* "acpi_call.c"
+ (("asm/uaccess\\.h")
+ "linux/uaccess.h"))
+ #t))
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each (lambda (file)
+ (let ((target (string-append doc "/" file)))
+ (mkdir-p (dirname target))
+ (copy-recursively file target)))
+ (list "README.md" "examples"))
+ #t))))))
+ (home-page "https://github.com/teleshoes/acpi_call")
+ (synopsis "Linux kernel module to perform ACPI method calls")
+ (description
+ "This simple Linux kernel module allows calls from user space to any
+@acronym{ACPI, Advanced Configuration and Power Interface} method provided by
+your computer's firmware, by writing to @file{/proc/acpi/call}. You can pass
+any number of parameters of types @code{ACPI_INTEGER}, @code{ACPI_STRING},
+and @code{ACPI_BUFFER}.
+
+It grants direct and undocumented access to your hardware that may cause damage
+and should be used with caution, especially on untested models.")
+ (license license:gpl3+))) ; see README.md (no licence headers)
+
+(define-public vhba-module
+ (package
+ (name "vhba-module")
+ (version "20190410")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.sourceforge.net/cdemu/vhba-module/vhba-module-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1513hq130raxp9z5grj54cwfjfxj05apipxg425j0zicii59a60c"))))
+ (build-system linux-module-build-system)
+ (arguments
+ ;; TODO: No tests?
+ `(#:tests? #f))
+ (home-page "https://cdemu.sourceforge.io/")
+ (synopsis "Kernel module that emulates SCSI devices")
+ (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+ (license license:gpl2+)))
+
+
+;;;
;;; Pluggable authentication modules (PAM).
;;;
@@ -3696,6 +3770,68 @@ other @code{hwmon} driver that enables temperature reading and fan control
from userspace.")
(license license:gpl3+)))
+(define-public tpacpi-bat
+ (package
+ (name "tpacpi-bat")
+ (version "3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/teleshoes/tpacpi-bat.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wbaz34z99gqx721alh5vmpxpj2yxg3x9m8jqyivfi1wfpwc2nd5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-inputs
+ (lambda _
+ (substitute* "tpacpi-bat"
+ (("cat ")
+ (format "~a " (which "cat")))
+ ;; tpacpi-bat modprobes the acpi_call kernel module if it's not
+ ;; loaded. That's the administrator's prerogative; disable it.
+ (("system \"(modprobe .*)\"" _ match)
+ (format "die \"Please run ‘~a’ first.\\n\"" match)))
+ #t))
+ (delete 'configure) ; nothing to configure
+ (delete 'build) ; nothing to build
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (install-file "tpacpi-bat" bin)
+
+ ;; There's no man page. Install other forms of documentation.
+ (for-each (lambda (file)
+ (let ((target (string-append doc "/" file)))
+ (mkdir-p (dirname target))
+ (copy-recursively file target)))
+ (list "battery_asl" "examples" "README.md"))
+ #t))))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "https://github.com/teleshoes/tpacpi-bat")
+ (synopsis "ThinkPad battery charge controller")
+ (description
+ "Tpacpi-bat is a command-line interface to control battery charging on
+@uref{https://github.com/teleshoes/tpacpi-bat/wiki/Supported-Hardware, Lenovo
+ThinkPad models released after 2011}, starting with the xx20 series. It can
+query and set the thresholds at which one or both batteries will start and stop
+charging, inhibit charging batteries for a set period of time, or force them to
+discharge when they otherwise would not.
+
+This tool merely exposes ACPI calls provided by the @code{acpi_call} Linux
+kernel module provided by the @code{acpi-call-linux-module} package, which must
+be installed and loaded separately. Only the original vendor firmware is
+supported.")
+ (license license:gpl3+)))
+
(define-public ntfs-3g
(package
(name "ntfs-3g")
@@ -4641,15 +4777,16 @@ userspace queueing component and the logging subsystem.")
(package
(name "proot")
(version "5.1.0")
- (home-page "https://github.com/proot-me/PRoot")
- (source (origin
- (method url-fetch)
- (uri (string-append home-page "/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "11h30i83vdhc3khlj6hrh3a21sbmmz8nhfv09vkf6b9bcs1biz2h"))
- (patches (search-patches "proot-test-fhs.patch"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/proot-me/PRoot.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0azsqis99gxldmbcg43girch85ysg4hwzf0h1b44bmapnsm89fbz"))
+ (patches (search-patches "proot-test-fhs.patch"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("-C" "src")
@@ -4726,6 +4863,7 @@ userspace queueing component and the logging subsystem.")
;; For 'mcookie', used by some of the tests.
("util-linux" ,util-linux)))
(inputs `(("talloc" ,talloc)))
+ (home-page "https://github.com/proot-me/PRoot")
(synopsis "Unprivileged chroot, bind mount, and binfmt_misc")
(description
"PRoot is a user-space implementation of @code{chroot}, @code{mount --bind},