summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index edbbdfffb7..6387f71582 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -479,7 +479,10 @@ large scale eigenvalue problems.")
(inputs
`(("mpi" ,openmpi)
,@(package-inputs arpack-ng)))
- (arguments `(#:configure-flags '("--enable-mpi")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments arpack-ng)
+ ((#:configure-flags _ '())
+ ''("--enable-mpi"))))
(synopsis "Fortran subroutines for solving eigenvalue problems with MPI")))
(define-public lapack