summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm29
1 files changed, 10 insertions, 19 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7fe58094c0..1576447773 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -743,7 +743,8 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
+ (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))
+ (patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
`(#:imported-modules
@@ -756,16 +757,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'add-plugin-dirs
- (lambda _
- (substitute* "gajim/common/configpaths.py"
- (("_paths\\['PLUGINS_USER'\\]\\]")
- "_paths['PLUGINS_USER']] + \
-([os.getenv('GAJIM_PLUGIN_PATH')] \
-if os.getenv('GAJIM_PLUGIN_PATH') \
-and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() \
-else [])"))
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -859,7 +850,7 @@ and OpenPGP) and available in 29 languages.")
(define-public gajim-omemo
(package
(name "gajim-omemo")
- (version "2.7.9")
+ (version "2.6.80")
(source
(origin
(method url-fetch/zipbomb)
@@ -868,7 +859,7 @@ and OpenPGP) and available in 29 languages.")
"https://ftp.gajim.org/plugins_releases/omemo_"
version ".zip"))
(sha256
- (base32 "19si2v5yrxpn2m0f684npsg0iiyl2h3r5hbxyrxv4k3acmfmhb3z"))))
+ (base32 "179hgx091c12258335znn1540jhp4z3n3wv5ksrgqq7l3jgc93d7"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -897,7 +888,7 @@ multi-client end-to-end encryption.")
(define-public gajim-openpgp
(package
(name "gajim-openpgp")
- (version "1.3.5")
+ (version "1.2.14")
(source
(origin
(method url-fetch/zipbomb)
@@ -906,7 +897,7 @@ multi-client end-to-end encryption.")
"https://ftp.gajim.org/plugins_releases/openpgp_"
version ".zip"))
(sha256
- (base32 "1jvpl2gjl5xxvsgxpmvh3mn2mm142dg2hknakkc32swb7l1fqx5m"))))
+ (base32 "0wdjpf1i4pvl4ha4plfpywwi9aw5n2mhrpv8mmbidpawxqfbd94b"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -931,7 +922,7 @@ Encryption to Gajim.")
(define-public dino
(package
(name "dino")
- (version "0.1.0")
+ (version "0.2.0")
(outputs '("out" "debug"))
(source
(origin
@@ -940,7 +931,7 @@ Encryption to Gajim.")
version "/dino-" version ".tar.gz"))
(sha256
(base32
- "0dcq2jhpywgxrp9x1qqmrl2z50hazspqj547b9zz70apy3y4418h"))))
+ "0iigh7bkil6prf02dqcl6lmd89jxz685h8lqr3ni4x39zkcransn"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f
@@ -2373,7 +2364,7 @@ support for high performance Telegram Bot creation.")
(define-public chatty
(package
(name "chatty")
- (version "0.1.16")
+ (version "0.1.17")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2382,7 +2373,7 @@ support for high performance Telegram Bot creation.")
(file-name (git-file-name name version))
(sha256
(base32
- "085hb3ii1cy0jb3f0mim25v5r5w3gpfsdpjid5dmrpw4gi88aa2x"))))
+ "0ba1rw8a3vif9k3570hxjfm25vqys3vk3f6g8z5irklwq4bi6lmn"))))
(build-system meson-build-system)
(arguments
'(#:phases