summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9826a36034..15f564a35d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2019 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017, 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -1910,7 +1910,7 @@ with a selectable pattern matrix size.")
(package
(inherit bsequencer)
(name "bchoppr")
- (version "1.10.10")
+ (version "1.12.0")
(source
(origin
(method git-fetch)
@@ -1919,7 +1919,7 @@ with a selectable pattern matrix size.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0gxz0cpxdfj7ajcd9yg05d26i7p24mx5865vy3ph76ni8kycdlrc"))))
+ (base32 "1jfp98qa0frmdybrg71fn8wxn1b3ginkbkcg9cz9y83j1m0jqrif"))))
(synopsis "Audio stream-chopping LV2 plugin")
(description "B.Choppr cuts the audio input stream into a repeated
sequence of up to 16 chops. Each chop can be leveled up or down (gating).
@@ -2300,10 +2300,10 @@ perform creative live mixes with digital music files.")
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://synthv1.sourceforge.io")
(synopsis "Polyphonic subtractive synthesizer")
(description
@@ -2333,10 +2333,10 @@ oscillators and stereo effects.")
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://drumkv1.sourceforge.io")
(synopsis "Drum-kit sampler synthesizer with stereo effects")
(description
@@ -2366,10 +2366,10 @@ effects.")
alsa-lib
new-session-manager
liblo
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://samplv1.sourceforge.io")
(synopsis "Polyphonic sampler synthesizer with stereo effects")
(description
@@ -2399,10 +2399,10 @@ effects.")
new-session-manager
liblo
fftwf
- qtbase-5
- qtsvg-5))
+ qtbase
+ qtsvg))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://padthv1.sourceforge.io")
(synopsis "Polyphonic additive synthesizer")
(description
@@ -3313,14 +3313,13 @@ from the command line.")
libvorbis
lilv
lv2
- qtbase-5
- qtsvg-5
- qtx11extras
+ qtbase
+ qtsvg
rubberband
suil
zlib))
(native-inputs
- (list pkg-config qttools-5))
+ (list pkg-config qttools))
(home-page "https://qtractor.org/")
(synopsis "Audio/MIDI multi-track sequencer")
(description