summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm68
1 files changed, 59 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index abc616de3c..5a0c464252 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -87,6 +87,7 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages ssh)
@@ -580,7 +581,7 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "2.6.3")
+ (version "2.6.4")
(source
(origin
(method url-fetch)
@@ -588,7 +589,7 @@ of the same name.")
version ".tar.xz"))
(sha256
(base32
- "1v538h02y8avwy3cr11xz6wkyf9xd8qva4ng4sl9f2fw4skahn6i"))))
+ "0qf81dk726sdsmjqa9nd251j1cwvzkyb4hrlp6w4iwa3cdz00sx0"))))
(build-system gnu-build-system)
(inputs `(("c-ares" ,c-ares)
("glib" ,glib)
@@ -651,7 +652,7 @@ network frames.")
(define-public fping
(package
(name "fping")
- (version "4.0")
+ (version "4.1")
(source
(origin
(method url-fetch)
@@ -659,9 +660,9 @@ network frames.")
version ".tar.gz"))
(sha256
(base32
- "1kp81wchi79l8z8rrj602fpjrd8bi84y3i7fsaclzlwap5943sv7"))))
+ "0wxbvm480vij8dy4v1pi8f0c7010rx6bidg3qhsvkdf2ijhy4cr7"))))
(build-system gnu-build-system)
- (home-page "http://fping.org/")
+ (home-page "https://fping.org/")
(synopsis "Send ICMP ECHO_REQUEST packets to network hosts")
(description
"fping is a ping like program which uses the Internet Control Message
@@ -673,6 +674,55 @@ send out a ping packet and move on to the next target in a round-robin
fashion.")
(license license:expat)))
+(define-public gandi.cli
+ (package
+ (name "gandi.cli")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32 "0vfzkw1avybjkf6fwqpf5m4kjz4c0qkkmj62f3jd0zx00vh5ly1d"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'embed-store-file-names
+ (lambda _
+ (substitute* (list "gandi/cli/modules/cert.py"
+ "gandi/cli/tests/commands/test_certificate.py")
+ (("openssl") (which "openssl")))
+ #t))
+ (add-after 'install 'install-documentation
+ ;; The included man page may be outdated but we install it anyway,
+ ;; since it's mentioned in 'gandi --help' and better than nothing.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man1 (string-append out "/share/man/man1")))
+ (mkdir-p man1)
+ (with-output-to-file (string-append man1 "/gandi.1")
+ (lambda _
+ (invoke "rst2man.py" "gandicli.man.rst")))
+ #t))))))
+ (native-inputs
+ `(("python-docutils" ,python-docutils) ; for rst2man.py
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-tox" ,python-tox)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("python-click" ,python-click)
+ ("python-ipy" ,python-ipy)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests)))
+ (home-page "https://cli.gandi.net")
+ (synopsis "Command-line interface to the Gandi.net Web API")
+ (description
+ "This package provides a command-line client (@command{gandi}) to buy,
+manage, and delete Internet resources from Gandi.net such as domain names,
+virtual machines, and certificates.")
+ (license license:gpl3+)))
+
(define-public httping
(package
(name "httping")
@@ -852,7 +902,7 @@ private (reserved).")
(define-public perl-net-dns
(package
(name "perl-net-dns")
- (version "1.17")
+ (version "1.18")
(source
(origin
(method url-fetch)
@@ -864,7 +914,7 @@ private (reserved).")
version ".tar.gz")))
(sha256
(base32
- "1q62w9rf2w8kjzqagzr0rdn20ybl8gj3l6cdq4k8fw0sxa7zsycs"))))
+ "1lx902cbvlfl63bqfdrnyavmfwbjvrfdnwgdc1dgs1wpzja19kjj"))))
(build-system perl-build-system)
(inputs
`(("perl-digest-hmac" ,perl-digest-hmac)))
@@ -877,7 +927,7 @@ private (reserved).")
(define-public perl-socket6
(package
(name "perl-socket6")
- (version "0.28")
+ (version "0.29")
(source
(origin
(method url-fetch)
@@ -887,7 +937,7 @@ private (reserved).")
".tar.gz"))
(sha256
(base32
- "11j5jzqbzmwlws9zals43ry2f1nw9qy6im7yhn9ck5rikywrmm5z"))))
+ "054izici8klfxs8hr5rljib28plijpsfymy99xbzdp047bx1b2a6"))))
(build-system perl-build-system)
(arguments
`(#:phases