summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 20 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3b4fcf108b..95ddea92c5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -134,6 +134,8 @@
(sha256
(base32
"1f5gl3hzvixbgk0v3kmxiyn432znyy3jh5fa65cfzcaxzgfv1i1c"))
+ (patches (search-patches
+ "camlboot-dynamically-allocate-stack-signal.patch"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -317,7 +319,9 @@ functional, imperative and object-oriented styles of programming.")
"http://caml.inria.fr/pub/distrib/ocaml-"
(version-major+minor version)
"/ocaml-" version ".tar.xz"))
- (patches (search-patches "ocaml-4.09-multiple-definitions.patch"))
+ (patches (search-patches
+ "ocaml-4.09-multiple-definitions.patch"
+ "ocaml-4.09-dynamically-allocate-signal-stack.patch"))
(sha256
(base32
"1v3z5ar326f3hzvpfljg4xj8b9lmbrl53fn57yih1bkbx3gr3yzj"))))
@@ -366,7 +370,9 @@ patch-/bin/sh-references: ~a: changing `\"/bin/sh\"' to `~a'~%"
(sha256
(base32
"1f07hgj5k45cylj1q3k5mk8yi02cwzx849b1fwnwia8xlcfqpr6z"))
- (patches (search-patches "ocaml-multiple-definitions.patch"))
+ (patches (search-patches
+ "ocaml-multiple-definitions.patch"
+ "ocaml-4.07-dynamically-allocate-signal-stack.patch"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -6654,7 +6660,12 @@ the OCaml code.")
(substitute* "test/ppx_import_support/test.ml"
(("\\(Failure") "Failure")
((" \"(Some ppx-es.*)\")" _ m)
- (string-append " \"" m "\"."))))))))
+ (string-append " \"" m "\".")))))
+ (add-after 'fix-test-format 'fix-egrep
+ (lambda _
+ ;; egrep is obsolescent; using grep -E
+ (substitute* "test/expansion_context/run.t"
+ (("egrep") "grep -E")))))))
(propagated-inputs
(list ocaml-compiler-libs
ocaml-ppx-derivers
@@ -9219,7 +9230,12 @@ variants.")
"test/bin/mdx-test/misc/no-such-prelude/test.expected")
(("`") "'")
(("COMMAND") "[COMMAND]")
- (("\\.\\.\\.") "…")))))))
+ (("\\.\\.\\.") "…"))))
+ (add-after 'fix-test-format 'fix-egrep
+ (lambda _
+ ;; egrep is obsolescent; using grep -E
+ (substitute* "test/bin/mdx-test/expect/padding/test-case.md"
+ (("egrep") "grep -E")))))))
(propagated-inputs
(list ocaml-fmt
ocaml-astring