summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm65
1 files changed, 58 insertions, 7 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index aa24798071..cbda40f78b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -961,6 +961,57 @@ transactions from C or Python.")
;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
(license license:gpl2+)))
+(define-public bffe
+ (let ((commit "722c37ec8a23835edfc85cba3d89868592a2ed2d")
+ (revision "2"))
+ (package
+ (name "bffe")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.cbaines.net/guix/bffe")
+ (commit commit)))
+ (sha256
+ (base32
+ "05i4awyirp440pk4vwa0sf46gi801zv839qm1i2z7jipm1xfwaxx"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config
+ autoconf
+ automake
+
+ ;; Guile libraries are needed here for cross-compilation.
+ guile-next
+ guile-gnutls
+ guile-json-4
+ guix
+ guix-data-service
+ guix-build-coordinator
+ guile-fibers-1.3
+ guile-prometheus
+ guile-lib))
+ (propagated-inputs
+ (list guile-gnutls
+ guile-json-4
+ guix
+ guix-data-service
+ guix-build-coordinator
+ guile-fibers-1.3
+ guile-prometheus
+ guile-lib))
+ (home-page "https://git.cbaines.net/guix/bffe")
+ (synopsis "Build Farm Front-end for Guix")
+ (description
+ "The BFFE of Build Farm Front-end is an experimental frontend for Guix
+build farms. It works together with the Guix Data Service and Guix Build
+Coordinator to submit builds and monitor the activity.
+
+It functions as a Guile library, with the @code{run-bffe-service} procedure in
+the @code{(bffe)} module as the entry point.")
+ (license license:gpl3+))))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")
@@ -1450,8 +1501,8 @@ environments.")
"0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc")))))))
(define-public guix-build-coordinator
- (let ((commit "cbded42c284cca4ecaaebbf0a666cf89efc465a7")
- (revision "88"))
+ (let ((commit "9c42dcb726fc925606b12695e195ae1dc7e28cc3")
+ (revision "89"))
(package
(name "guix-build-coordinator")
(version (git-version "0" revision commit))
@@ -1462,7 +1513,7 @@ environments.")
(commit commit)))
(sha256
(base32
- "1z2wdf5h4dxq9g7a6j7nvmrsqcibrfm8nmkakqgz7ipcxyk0vzjx"))
+ "18m368rgmaiscmr1jlz77qkfw5fp4m8szgh90l6wbi9w68yfmr4n"))
(file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -1771,7 +1822,7 @@ in an isolated environment, in separate namespaces.")
guile-gnutls
;; Guile libraries are needed here for cross-compilation.
- (car (assoc-ref (package-native-inputs guix) "guile"))
+ guile-next
guile-json-4
guile-gcrypt
guix
@@ -1783,7 +1834,7 @@ in an isolated environment, in separate namespaces.")
guile-sqlite3))
(inputs
(list bash-minimal
- (car (assoc-ref (package-native-inputs guix) "guile"))))
+ guile-next))
(propagated-inputs
(list guile-json-4
guile-gcrypt
@@ -1870,7 +1921,7 @@ for packaging and deployment of cross-compiled Windows applications.")
(define-public libostree
(package
(name "libostree")
- (version "2022.7")
+ (version "2023.5")
(source
(origin
(method url-fetch)
@@ -1878,7 +1929,7 @@ for packaging and deployment of cross-compiled Windows applications.")
"https://github.com/ostreedev/ostree/releases/download/v"
(version-major+minor version) "/libostree-" version ".tar.xz"))
(sha256
- (base32 "07s14awf9ynlp84s08dkbwj9i18g93y0yf0k87nbks4l3hkakqlb"))))
+ (base32 "056v7bz40dx8k2j2pfypc4shl6ijzvx1gy8r0kaw66py67xklndw"))))
(build-system gnu-build-system)
(arguments
'(#:phases