summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/xpra-4.2-install_libs.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/xpra-4.2-install_libs.patch b/gnu/packages/patches/xpra-4.2-install_libs.patch
new file mode 100644
index 0000000000..92193df34a
--- /dev/null
+++ b/gnu/packages/patches/xpra-4.2-install_libs.patch
@@ -0,0 +1,33 @@
+This workaround for Gentoo interferes with our use of --no-compile during
+the 'install stage.
+
+--- a/setup.py 1970-01-01 01:00:01.000000000 +0100
++++ b/setup.py 2022-01-06 14:08:46.710437071 +0100
+@@ -561,12 +561,6 @@
+ % (cython_version, min_version))
+
+ def cython_add(extension, min_version="0.20"):
+- #gentoo does weird things, calls --no-compile with build *and* install
+- #then expects to find the cython modules!? ie:
+- #python2.7 setup.py build -b build-2.7 install --no-compile \
+- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
+ assert cython_ENABLED, "cython compilation is disabled"
+ cython_version_check(min_version)
+ from Cython.Distutils import build_ext
+@@ -1691,14 +1685,6 @@
+ if uinput_ENABLED:
+ add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
+
+- #gentoo does weird things, calls --no-compile with build *and* install
+- #then expects to find the cython modules!? ie:
+- #> python2.7 setup.py build -b build-2.7 install --no-compile \
+- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+- #otherwise we use the flags to skip pkgconfig
+- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
+- pkgconfig = no_pkgconfig
+-
+ if OSX and "py2app" in sys.argv:
+ import py2app #@UnresolvedImport
+ assert py2app is not None