summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5fd8a2d0eb..35147ebfa7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -476,6 +476,8 @@ concepts.")
(modify-phases %standard-phases
(replace 'check
(lambda _
+ ;; XXX: A Python 2 test fails when HOME=/homeless-shelter.
+ (setenv "HOME" "/tmp")
(invoke "python" "sh.py" "test"))))))
(native-inputs
`(("python-coverage" ,python-coverage)))
@@ -14704,7 +14706,7 @@ introspection.")
(synopsis "File transport adapter for Requests")
(description
"Requests-File is a transport adapter for use with the Requests Python
-library to allow local filesystem access via file:// URLs.")
+library to allow local file system access via @code{file://} URLs.")
(license license:asl2.0)))
(define-public python2-requests-file
@@ -14950,7 +14952,7 @@ and de-serializing Python objects to the majority of the built-in Python
types. Dill provides the user the same interface as the @code{pickle} module,
and also includes some additional features. In addition to pickling Python
objects, @code{dill} provides the ability to save the state of an interpreter
-session in a single command. Hence, it would be feasable to save a
+session in a single command. Hence, it would be feasible to save a
interpreter session, close the interpreter, ship the pickled file to another
computer, open a new interpreter, unpickle the session and thus continue from
the saved state of the original interpreter session.")