summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3de73c76a5..8714cc1d31 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1608,7 +1608,7 @@ code introspection, and logging.")
(("def test_remove_dir_prefix\\(self\\):")
"@pytest.mark.xfail\n def test_remove_dir_prefix(self):")))))
(build-system python-build-system)
- (inputs
+ (native-inputs
`(("python-py" ,python-py)
("python-nose" ,python-nose)
("python-mock" ,python-mock)))
@@ -2042,7 +2042,7 @@ and sensible default behaviors into your setuptools run.")
(propagated-inputs
`(("python-six" ,python-six)
("python-pbr-0.11" ,python-pbr-0.11)))
- (inputs
+ (native-inputs
`(;; Tests
("python-testtools" ,python-testtools)))
(arguments
@@ -2074,7 +2074,7 @@ Python tests.")
(propagated-inputs
`(("python-fixtures-0.3.16" ,python-fixtures-0.3.16)
("python-testtools" ,python-testtools)))
- (inputs
+ (native-inputs
`(("python-subunit" ,python-subunit)
("python-mimeparse" ,python-mimeparse)))
(home-page "https://launchpad.net/testrepository")
@@ -2579,7 +2579,7 @@ object.")
(substitute* "tests/test_virtualenv.py"
(("skipif.*") "skipif(True, reason=\"Guix\")\n"))
(zero? (system* "py.test")))))))
- (inputs
+ (native-inputs
`(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)))
(home-page "https://virtualenv.pypa.io/")