summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm66
1 files changed, 63 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2f518d940d..4b306952c1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -2064,7 +2064,7 @@ capabilities.")
(define-public python-pyparsing
(package
(name "python-pyparsing")
- (version "2.0.2")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
@@ -2072,7 +2072,7 @@ capabilities.")
"/pyparsing-" version ".tar.gz"))
(sha256
(base32
- "01lasib0n2fp2k99c988qhz16lm9hcwmnmrmhybdb3jq2xmkvr0p"))))
+ "0kw4py7gn45j93q8r7bzajfrjdc3xlsn2yzln41lf9zmrghjkrq6"))))
(build-system python-build-system)
(outputs '("out" "doc"))
(arguments
@@ -2788,3 +2788,63 @@ computing.")
,@(alist-delete "python-numpydoc"
(alist-delete "python-matplotlib"
(package-inputs ipython))))))))
+
+(define-public python-isodate
+ (package
+ (name "python-isodate")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/i/isodate/isodate-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1yqjn0is0p64cmk9xhq4hc6q06jk86d60kg2jws58d78q0qysami"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page
+ "http://cheeseshop.python.org/pypi/isodate")
+ (synopsis
+ "Python date parser and formatter")
+ (description
+ "Python-isodate is a python module for parsing and formatting
+ISO 8601 dates, time and duration.")
+ (license bsd-3)))
+
+(define-public python2-isodate
+ (package-with-python2 python-isodate))
+
+(define-public python-html5lib
+ (package
+ (name "python-html5lib")
+ (version "1.0b3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/h/html5lib/html5lib-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1l5i6xzckzx4hnh9qzv9q3kyhkgjx2hsi2k9srgci3qizjmvp6ln"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments
+ `(#:test-target "check"))
+ (home-page
+ "https://github.com/html5lib/html5lib-python")
+ (synopsis
+ "Python HTML parser based on the WHATWG HTML specifcation")
+ (description
+ "Html5lib is an HTML parser based on the WHATWG HTML specifcation
+and written in Python.")
+ (license expat)))
+
+(define-public python2-html5lib
+ (package-with-python2 python-html5lib))