summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 834c0dfbd4..feb78731c2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2019-2022 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017, 2018, 2019 Christopher Baines <mail@cbaines.net>
@@ -162,8 +162,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.7
(package
(inherit ruby-2.6)
- (version "2.7.4")
- (replacement ruby-2.7-fixed) ; security fixes
+ (version "2.7.6")
(source
(origin
(inherit (package-source ruby-2.6))
@@ -172,7 +171,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.gz"))
(sha256
(base32
- "0nxwkxh7snmjqf787qsp4i33mxd1rbf9yzyfiky5k230i680jhrh"))))
+ "042xrdk7hsv4072bayz3f8ffqh61i8zlhvck10nfshllq063n877"))))
(arguments
`(#:test-target "test"
#:configure-flags '("--enable-shared") ; dynamic linking
@@ -5501,8 +5500,9 @@ slowest tests in a minitest suite.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "script/test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "sh" "script/test")))))))
(native-inputs
(list bundler ruby-turn))
(synopsis "Pretty-print hashes and arrays in MiniTest")
@@ -6440,23 +6440,19 @@ across multiple CPU cores.")
(define-public ruby-parser
(package
(name "ruby-parser")
- (version "3.2.1.1")
+ (version "3.2.2.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "parser" version))
(sha256
(base32
- "1a2v5f8fw7nxm41xp422p1pbr41hafy62bp95m7vg42cqp5y4grc"))))
+ "0s5afi89p76k8vpwiqvh343pm5l23ijqlpszhz65afym3zpkxhzx"))))
(build-system ruby-build-system)
- (arguments
- '(#:tests? #f)) ; tests not included in gem
- (native-inputs
- (list bundler ruby-cliver ruby-simplecov ruby-racc))
- (inputs
- (list ragel))
- (propagated-inputs
- (list ruby-ast))
+ (arguments '(#:tests? #f)) ; tests not included in gem
+ (native-inputs (list bundler ruby-cliver ruby-simplecov ruby-racc))
+ (inputs (list ragel))
+ (propagated-inputs (list ruby-ast))
(synopsis "Ruby parser written in pure Ruby")
(description
"This package provides a Ruby parser written in pure Ruby.")
@@ -10364,14 +10360,14 @@ neither too verbose nor too minimal.")
(define-public ruby-sqlite3
(package
(name "ruby-sqlite3")
- (version "1.4.2")
+ (version "1.4.4")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "sqlite3" version))
(sha256
(base32
- "0lja01cp9xd5m6vmx99zwn4r7s97r1w5cb76gqd8xhbm1wxyzf78"))))
+ "1z1wa639c278bsipczn6kv8b13fj85pi8gk7x462chqx6k0wm0ax"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -10382,7 +10378,7 @@ neither too verbose nor too minimal.")
(inputs
(list sqlite))
(native-inputs
- (list ruby-hoe ruby-rake-compiler ruby-mini-portile))
+ (list ruby-hoe ruby-rake-compiler ruby-mini-portile-2))
(synopsis "Interface with SQLite3 databases")
(description
"This module allows Ruby programs to interface with the SQLite3 database