summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm36
1 files changed, 10 insertions, 26 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 3cde6af5fe..55689a6c6d 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -130,16 +130,12 @@ a server that supports the SSH-2 protocol.")
(name "openssh")
(version "7.5p1")
(source (origin
- (method url-fetch)
- (uri (let ((tail (string-append name "-" version ".tar.gz")))
- (list (string-append "http://openbsd.cs.fau.de/pub/OpenBSD/OpenSSH/portable/"
- tail)
- (string-append "http://ftp.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
- tail)
- (string-append "http://ftp2.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/"
- tail))))
- (sha256 (base32
- "1w7rb5gbrikxdkp8w7zxnci4549gk4bw1lml01s59w5rzb2y6ilq"))))
+ (method url-fetch)
+ (uri (string-append "mirror://openbsd/OpenSSH/portable/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1w7rb5gbrikxdkp8w7zxnci4549gk4bw1lml01s59w5rzb2y6ilq"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)))
(inputs `(("openssl" ,openssl)
@@ -219,7 +215,7 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.11.0")
+ (version "0.11.2")
(home-page "https://github.com/artyom-poptsov/guile-ssh")
(source (origin
;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
@@ -231,19 +227,7 @@ Additionally, various channel-specific options can be negotiated.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
- (patches (search-patches "guile-ssh-rexec-bug.patch"
- "guile-ssh-double-free.patch"
- "guile-ssh-channel-finalization.patch"))
- (modules '((guix build utils)))
- (snippet
- ;; 'configure.ac' mistakenly tries to link files from examples/
- ;; that are not instantiated yet. Work around it.
- '(substitute* "configure.ac"
- (("AC_CONFIG_LINKS\\(\\[examples/([^:]+):.*" _ file)
- (string-append "AC_CONFIG_FILES([examples/" file
- "], [chmod +x examples/"
- file "])\n"))))))
+ "1w0k5s09xj5xycb7lbp5b7rm0xncclms3jwl98lwj8fxwngi1s90"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(arguments
@@ -347,13 +331,13 @@ authentication scheme.")
(define-public mosh
(package
(name "mosh")
- (version "1.3.0")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
(sha256
(base32
- "0xikz40q873g9ihvz3x6bwkcb9hb8kcnp5wpcmb72pg5c7s143ij"))))
+ "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
(build-system gnu-build-system)
(arguments
'(#:phases