summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm92
1 files changed, 36 insertions, 56 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 13f177c399..d17061205f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Vicente Vera Parra <vicentemvp@gmail.com>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -115,7 +115,7 @@
(define-public pspp
(package
(name "pspp")
- (version "1.4.1")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
@@ -123,11 +123,16 @@
version ".tar.gz"))
(sha256
(base32
- "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
+ "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
(build-system gnu-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-test-suite
+ (lambda _
+ (substitute* "tests/output/tex.at"
+ (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
+ "AT_CHECK([LC_ALL=en_US.UTF-8 pspp"))))
(add-before 'check 'prepare-tests
;; Prevent irrelevant errors that cause test output mismatches:
;; ‘Fontconfig error: No writable cache directories’
@@ -149,7 +154,7 @@
`(,glib "bin") ;for glib-genmarshal
perl
pkg-config
- python-2 ;for tests
+ python-3 ;for tests
texinfo))
(home-page "https://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis")
@@ -509,14 +514,14 @@ available, greatly increasing its breadth and scope.")
(define-public r-boot
(package
(name "r-boot")
- (version "1.3-28.1")
+ (version "1.3-30")
(source
(origin
(method url-fetch)
(uri (cran-uri "boot" version))
(sha256
(base32
- "0lzz08fpn80qzm197s4806hr6skanr3r3rlx6bx7zk4cripygkfl"))))
+ "15zysf5manfsap7x0zvjzgdvs9whv137iasjydp1php6sqmxc2am"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/boot")
(synopsis "Bootstrap functions for R")
@@ -998,19 +1003,20 @@ OpenSSL should be used.")
(define-public r-estimability
(package
(name "r-estimability")
- (version "1.4.1")
+ (version "1.5")
(source (origin
(method url-fetch)
(uri (cran-uri "estimability" version))
(sha256
(base32
- "090i1xwdp4fwj8jr8nk13w49516lfkk5mq1w7l0lff9g8lgaynn6"))))
+ "0s6w8vnq0jc136d2mpf6pgg45rbxccrlsgdy89pgksnbaxhmyb5k"))))
(build-system r-build-system)
+ (native-inputs (list r-knitr))
(home-page "https://cran.r-project.org/web/packages/estimability")
(synopsis "Tools for assessing estimability of linear predictions")
- (description "Provides tools for determining estimability of linear
-functions of regression coefficients, and @code{epredict} methods that handle
-non-estimable cases correctly.")
+ (description "This package provides tools for determining estimability of
+linear functions of regression coefficients, and @code{epredict} methods that
+handle non-estimable cases correctly.")
(license license:gpl2+)))
(define-public r-labeling
@@ -1258,13 +1264,13 @@ using just two functions: melt and dcast (or acast).")
(define-public r-ggplot2
(package
(name "r-ggplot2")
- (version "3.4.4")
+ (version "3.5.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggplot2" version))
(sha256
- (base32 "0iiywrzv8j0npasvzgkxwhw0zqisf4xmpx06jl0lsq1ybl3fqxid"))))
+ (base32 "1qlh231dwsa7j0pzlw6xdm68d7r0v64916p66bg9lh1dw3a1ryh7"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -1296,13 +1302,13 @@ aesthetic attributes.")
(define-public r-ggdendro
(package
(name "r-ggdendro")
- (version "0.1.23")
+ (version "0.2.0")
(source (origin
(method url-fetch)
(uri (cran-uri "ggdendro" version))
(sha256
(base32
- "1f4fz9llmbpb8gh90aid7dvriadx16xdhsl7832yw4pyqj4fjcrs"))))
+ "0sdayyzvhkbli0ha68mc0f7cgp36njv9ign37d63l21hvd6w6h0r"))))
(build-system r-build-system)
(propagated-inputs
(list r-ggplot2 r-mass))
@@ -1322,14 +1328,14 @@ agnes cluster diagrams.")
(define-public r-gdtools
(package
(name "r-gdtools")
- (version "0.3.5")
+ (version "0.3.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "gdtools" version))
(sha256
(base32
- "155qa55wr9vf2j2j4qjqqlkdaqlvvlvsm2wmysnhli47bfh6vd4c"))))
+ "1d1sidm2qi1nrp1hhf010xji66aj8sn833fv4a39gli2c560p4i6"))))
(build-system r-build-system)
(native-inputs
(list pkg-config))
@@ -3824,13 +3830,13 @@ using the multicore functionality of the parallel package.")
"datatables-extensions/Buttons"))))
(package
(name "r-dt")
- (version "0.31")
+ (version "0.32")
(source (origin
(method url-fetch)
(uri (cran-uri "DT" version))
(sha256
(base32
- "11wwd76x1bk9aswi8w4bmvbf51j8hlmb5gsyqzfjdi6ihjkl4vwm"))
+ "0nvj2bc441b9h13085fa7q281f86lgx4k0d8lr64xgdpbmbvkl21"))
(modules '((guix build utils)
(ice-9 match)))
(snippet
@@ -4988,14 +4994,14 @@ conversion of R objects to LaTeX code, and recoding variables.")
(define-public r-runit
(package
(name "r-runit")
- (version "0.4.32")
+ (version "0.4.33")
(source
(origin
(method url-fetch)
(uri (cran-uri "RUnit" version))
(sha256
(base32
- "1wc1gwb7yw7phf8b0gkig6c23klya3ax11c6i4s0f049k42r78r3"))))
+ "0pybwvd57vf71vvlxdrynw5n6s5gnbqnwvq0qpd395ggqypwb95j"))))
(properties `((upstream-name . "RUnit")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/RUnit")
@@ -5613,14 +5619,14 @@ models, generalized linear models and model-based clustering.")
(define-public r-mclust
(package
(name "r-mclust")
- (version "6.0.1")
+ (version "6.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "mclust" version))
(sha256
(base32
- "0zsk89r2l73zi1dy0195k84n4dqdp97yisll5kg16amxs5pxx4hf"))))
+ "0mchdxkc3y0v6dw8fzjnlqd6f3zrafm3xf1c53s6ps529b66kx2x"))))
(build-system r-build-system)
(native-inputs
(list gfortran r-knitr))
@@ -6807,8 +6813,8 @@ Java package that provides routines for various statistical distributions.")
(license license:gpl2+)))
(define-public emacs-ess
- (let ((commit "3691ecc642eab5d016887e42699648e0eeeef566")
- (version "18.10.2")
+ (let ((commit "ab2faeca1ba6c456333312c58f58ef9e5ef4aa8b")
+ (version "24.01.1")
(revision "1"))
(package
(name "emacs-ess")
@@ -6820,7 +6826,7 @@ Java package that provides routines for various statistical distributions.")
(url "https://github.com/emacs-ess/ESS")
(commit commit)))
(sha256
- (base32 "19p8djsbgvahpsx1w8i6h3qvpbdr4isjwm3wi82yk2648ri0qsq1"))
+ (base32 "0jfdfqpa3x1zm65cllkzhqir057xd3hxi4z2ddii1i26zy56iikf"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
@@ -6838,9 +6844,6 @@ Java package that provides routines for various statistical distributions.")
;; Stop install-info from trying to update the info directory.
(substitute* "doc/Makefile"
((".*/dir.*") ""))
- ;; Fix r-help-mode test.
- (substitute* "test/ess-test-r.el"
- (("\\(equal ess-help-object \"plot.default\")") "t"))
;; Avoid generating ess-autoloads.el twice.
(substitute* "Makefile"
(("all: lisp doc etc autoloads")
@@ -6870,9 +6873,6 @@ Java package that provides routines for various statistical distributions.")
#~(modify-phases %standard-phases
(delete 'configure)
(add-before 'check 'skip-failing-tests
- ;; The command-without-trailing-newline-test and other
- ;; tests fail for unknown reasons (see:
- ;; https://github.com/emacs-ess/ESS/issues/1272).
(lambda _
(let-syntax
((disable-tests
@@ -6884,22 +6884,7 @@ Java package that provides routines for various statistical distributions.")
(((string-append "^\\(ert-deftest " test-name ".*")
all)
(string-append all "(skip-unless nil)\n"))
- ...))))
- (disable-etests ;different test syntax
- (syntax-rules ()
- ((_ file ())
- (syntax-error "test names list must not be empty"))
- ((_ file (test-name ...))
- (emacs-batch-edit-file file
- '(progn
- (mapc (lambda (test)
- (goto-char (point-min))
- (search-forward
- (format "etest-deftest %s " test))
- (beginning-of-line)
- (kill-sexp))
- (list test-name ...))
- (basic-save-buffer)))))))
+ ...)))))
(disable-tests (list "test/ess-test-inf.el"
"test/ess-test-r.el")
("ess--derive-connection-path"
@@ -6909,15 +6894,10 @@ Java package that provides routines for various statistical distributions.")
"ess-r-load-ESSR-github-fetch-no"
"ess-r-load-ESSR-github-fetch-yes"
"ess-set-working-directory-test"
- "ess-test-r-startup-directory"))
- (disable-etests "test/ess-test-r-eval.el"
- ("ess-r-eval-ns-env-roxy-tracebug-test"
- "ess-r-eval-sink-freeze-test"))
- (disable-etests
- "test/ess-test-inf.el"
- ("command-without-trailing-newline-test")))))
+ "ess-test-r-startup-directory")))))
(replace 'check
- (lambda _ (invoke "make" "test")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "make" "test"))))))))
(native-inputs (list perl r-roxygen2 texinfo))
(inputs (list emacs-minimal r-minimal))
(propagated-inputs (list emacs-julia-mode))