summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm79
1 files changed, 58 insertions, 21 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 472a5eb38c..c19097dadd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -285,7 +286,7 @@ video and audio streams from a DVD.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/OpenVisualCloud/SVT-HEVC.git")
+ (url "https://github.com/OpenVisualCloud/SVT-HEVC")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -313,7 +314,7 @@ efficiency.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/Intel-Media-SDK/MediaSDK.git")
+ (url "https://github.com/Intel-Media-SDK/MediaSDK")
(commit (string-append "intel-" name "-" version))))
(file-name (git-file-name name version))
(sha256
@@ -489,7 +490,7 @@ and mmsh protocols.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/farindk/libvideogfx.git")
+ (url "https://github.com/farindk/libvideogfx")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -533,7 +534,7 @@ applications by providing high-level classes for commonly required tasks.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/strukturag/libde265.git")
+ (url "https://github.com/strukturag/libde265")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -574,7 +575,7 @@ other software.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/libts/tslib.git")
+ (url "https://github.com/libts/tslib")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -1006,7 +1007,7 @@ H.264 (MPEG-4 AVC) video streams.")
(define-public straw-viewer
(package
(name "straw-viewer")
- (version "0.1.0")
+ (version "0.1.1")
(source
(origin
(method git-fetch)
@@ -1015,7 +1016,7 @@ H.264 (MPEG-4 AVC) video streams.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0786bppk8dhp5p2284qp7pm3b9vwh1cm4n03hiqwd2vvgv41aypy"))))
+ (base32 "0idp1ayqghi5bg83v9qmvzz9wj05flwrp1fxb4kqa6vwxmprvhyk"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)
@@ -1227,6 +1228,8 @@ ASS/SSA (Advanced Substation Alpha/SubStation Alpha) subtitle format.")
(base32
"1x3j6yfyxl52adgnabycr0n38j9hx2j74la0hz0n8cnh9ry4d2qj"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-static")))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("freeglut" ,freeglut)
@@ -2185,14 +2188,14 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2020.11.01.1")
+ (version "2020.11.19")
(source (origin
(method url-fetch)
(uri (string-append "https://youtube-dl.org/downloads/latest/"
"youtube-dl-" version ".tar.gz"))
(sha256
(base32
- "06lhba4b9bm6f5yqrb5xvdr0l5shwd95djf9nlpg86prr5xihqks"))))
+ "17my2k6ksj2gch2j85laa5y8c448j4n6zfg85ljfg3zxnag4vhgq"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -2344,7 +2347,7 @@ other site that youtube-dl supports.")
(define-public you-get
(package
(name "you-get")
- (version "0.4.1456")
+ (version "0.4.1475")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2353,7 +2356,7 @@ other site that youtube-dl supports.")
(file-name (git-file-name name version))
(sha256
(base32
- "0n6h5qkhjwsxy8rf6n4i8hd8dah38hbvchh9272c53gydgp9lp29"))))
+ "1hsa99fgx1zhzkf3n0hlbinckvipd54vhs6y4jkq0rd9r6yc1h7f"))))
(build-system python-build-system)
(inputs
`(("ffmpeg" ,ffmpeg))) ; for multi-part and >=1080p videos
@@ -2478,7 +2481,8 @@ Both command-line and GTK2 interface are available.")
"1zxfnw1xbghcj7b3zz5djndv6gwssxda19cz1lrlqrkg8577r7kd"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--disable-bdjava-jar")
+ `(#:configure-flags '("--disable-bdjava-jar"
+ "--disable-static")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'refer-to-libxml2-in-.pc-file
@@ -2649,7 +2653,7 @@ for use with HTML5 video.")
(define-public avidemux
(package
(name "avidemux")
- (version "2.7.4")
+ (version "2.7.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2657,7 +2661,7 @@ for use with HTML5 video.")
"avidemux_" version ".tar.gz"))
(sha256
(base32
- "1acdb3m37vdzzbm8mwyibcn8msi7birb5v30qfi7jli5r00src3x"))
+ "1kwkn976ppahrcr74bnv6sqx75pzl9y21m1mvr5ksi1m6lgp924s"))
(patches (search-patches "avidemux-install-to-lib.patch"))))
(build-system cmake-build-system)
(native-inputs
@@ -2675,6 +2679,7 @@ for use with HTML5 video.")
("glu" ,glu)
("jack" ,jack-1)
("lame" ,lame)
+ ("libaom" ,libaom)
("libva" ,libva)
("libvdpau" ,libvdpau)
("libvorbis" ,libvorbis)
@@ -2689,7 +2694,7 @@ for use with HTML5 video.")
#:phases
;; Make sure files inside the included ffmpeg tarball are
;; patch-shebanged.
- (let ((ffmpeg "ffmpeg-4.1.4"))
+ (let ((ffmpeg "ffmpeg-4.2.3"))
(modify-phases %standard-phases
(add-before 'patch-source-shebangs 'unpack-ffmpeg
(lambda _
@@ -2987,11 +2992,40 @@ tools, XML authoring components, and an extensible plug-in based API.")
(base32
"1bkqlrizx0j2rd6ybam2x17bjrpwzl4v4szmnzm3cmixis3w3npr"))))
(build-system gnu-build-system)
+ ;; Separate graphical tools in order to save almost 1 GiB on the closure
+ ;; for the common case.
+ (outputs '("out" "gui"))
(arguments
'(#:configure-flags
- (list (string-append "--with-udevdir="
+ (list "--disable-static"
+ (string-append "--with-udevdir="
(assoc-ref %outputs "out")
- "/lib/udev"))))
+ "/lib/udev"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'split
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gui (assoc-ref outputs "gui")))
+ (mkdir-p (string-append gui "/bin"))
+ (mkdir-p (string-append gui "/share/man/man1"))
+ (mkdir-p (string-append gui "/share/applications"))
+ (for-each
+ (lambda (prog)
+ (for-each
+ (lambda (file)
+ (rename-file (string-append out file)
+ (string-append gui file)))
+ (list
+ (string-append "/bin/" prog)
+ (string-append "/share/man/man1/" prog ".1")
+ (string-append "/share/applications/" prog ".desktop"))))
+ '("qv4l2" "qvidcap"))
+ (copy-recursively (string-append out "/share/icons")
+ (string-append gui "/share/icons"))
+ (delete-file-recursively (string-append out "/share/icons"))
+ (rmdir (string-append out "/share/applications"))
+ #t))))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))
@@ -3765,7 +3799,7 @@ iTunes-style metadata.")
(define-public livemedia-utils
(package
(name "livemedia-utils")
- (version "2019.05.29")
+ (version "2020.11.19")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3773,11 +3807,12 @@ iTunes-style metadata.")
version ".tar.gz"))
(sha256
(base32
- "08i63jr8ihn1xiq5z5n3yls3yz6li5sg0s454l56p5bcvbrw81my"))))
+ "16w6yxdbmjdhvffnrb752dn4llf3l0wb00dgdkyia0vqsv2qqyn7"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
+ `(#:tests? #f ; no tests
+ #:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "CXX=" ,(cxx-for-target))
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib")
(string-append "PREFIX="
@@ -3792,6 +3827,8 @@ iTunes-style metadata.")
(lambda _
(invoke "./genMakefiles"
"linux-with-shared-libraries"))))))
+ (inputs
+ `(("openssl" ,openssl)))
(home-page "http://www.live555.com/liveMedia/")
(synopsis "Set of C++ libraries for multimedia streaming")
(description "This code forms a set of C++ libraries for multimedia