summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e9dc389bc5..45e857d3e0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14609,6 +14609,32 @@ based on diff output.")
based on diff output.")
(license license:gpl3+))))
+(define-public emacs-all-the-icons-dired
+ (let ((commit "980b7747d6c4a7992a1ec56afad908956db0a519")
+ (version "1.0")
+ (revision "1"))
+ (package
+ (name "emacs-all-the-icons-dired")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtbm37/all-the-icons-dired/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pvbgyxfj4j205nj1r02045f1y4wgavdsk7f45hxkkhms1rj8jyy"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+ (home-page "https://github.com/jtbm37/all-the-icons-dired/")
+ (synopsis "Show icons for each file in @code{dired-mode}")
+ (description "This package allows icons from @file{all-the-icons.el} to
+be used in @code{dired-mode}.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.