summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 0db2021910..b88df0109b 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1102,6 +1102,14 @@ partition."))
(modify-inputs (package-native-inputs base)
(append arm-trusted-firmware-rk3399))))))
+(define-public u-boot-qemu-arm
+ (make-u-boot-package "qemu_arm" "arm-linux-gnueabihf"
+ ;; Disable features that require OpenSSL due
+ ;; to GPL/Openssl license incompatibilities.
+ ;; See https://bugs.gnu.org/34717 for
+ ;; details.
+ #:configs '("# CONFIG_FIT_SIGNATURE is not set")))
+
(define-public u-boot-qemu-riscv64
(make-u-boot-package "qemu-riscv64" "riscv64-linux-gnu"))