summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ceb2f14a80..fc85560114 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2717,7 +2717,17 @@ satisfiability checking (SAT).")
(("ctl\\.solve\\(on_statistics=on_statistics\\)" all)
(string-append
all
- "; self.skipTest(\"You shall not fail.\")")))))))))
+ "; self.skipTest(\"You shall not fail.\")")))))
+ (add-after 'install 'install-distinfo
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (with-directory-excursion (python:site-packages inputs outputs)
+ (let ((dir (string-append "clingo-" #$version ".dist-info")))
+ (mkdir-p dir)
+ (call-with-output-file (string-append dir "/METADATA")
+ (lambda (port)
+ (format port "Metadata-Version: 1.1~%")
+ (format port "Name: clingo~%")
+ (format port "Version: ~a~%" #$version)))))))))))
(inputs (list clingo python-wrapper))
(propagated-inputs (list python-cffi))
(native-inputs (modify-inputs (package-native-inputs clingo)