summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1a19f51ccc..54921fdc86 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1192,7 +1193,7 @@ ciphers such as ChaCha20, Curve25519, NTRU, and Blake2b.")
(define-public aws-lc
(package
(name "aws-lc")
- ; Update only when updating aws-crt-cpp.
+ ;; Update only when updating aws-crt-cpp.
(version "1.0.2")
(source (origin
(method git-fetch)
@@ -1202,10 +1203,10 @@ ciphers such as ChaCha20, Curve25519, NTRU, and Blake2b.")
(file-name (git-file-name name version))
(sha256
(base32
- "14dhdddlph36nshdkh0v43718hxjx5vxqxmkw7707393q0qrgipw"))))
+ "16y4iy2rqrmb7b1c394wyq7a5vbjb41599524my6b6q1vk1pi307"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f ; re-enable but with go and perl dependencies
+ '(#:test-target "run_minimal_tests"
#:configure-flags
'("-DBUILD_SHARED_LIBS=ON")))
(synopsis "General purpose cryptographic library")