summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c7339eb00e..4a9cf3229c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1165,18 +1165,18 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
(define-public weston
(package
(name "weston")
- (version "9.0.0")
+ (version "10.0.2")
(source (origin
(method url-fetch)
(uri (string-append
- "https://wayland.freedesktop.org/releases/"
- "weston-" version ".tar.xz"))
+ "https://gitlab.freedesktop.org/wayland/weston/-/releases/"
+ version "/downloads/weston-" version ".tar.xz"))
(sha256
(base32
- "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
+ "1rs92p7sfkw9lqlkfnqh5af19ym3x8l3hp3yfv117m7qv6h6qr49"))))
(build-system meson-build-system)
(native-inputs
- (list mscgen pkg-config xorg-server))
+ (list mscgen pkg-config python-3 xorg-server))
(inputs
`(("cairo" ,cairo-xcb)
("colord" ,colord)
@@ -1203,8 +1203,8 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
("mtdev" ,mtdev)
("linux-pam" ,linux-pam)
("pango" ,pango)
- ("pipewire" ,pipewire)
- ("wayland-protocols" ,wayland-protocols)
+ ("pipewire" ,pipewire-0.3)
+ ("wayland-protocols" ,wayland-protocols-next)
("xorg-server-xwayland" ,xorg-server-xwayland)))
(propagated-inputs
(list libxkbcommon pixman wayland))