summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ed5d19497c..33bafe6b8e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8337,3 +8337,22 @@ arXiv, Google Scholar, Library of Congress, etc.
using @kbd{M-up} or @kbd{M-down} if a region is marked, it will move the
region instead.")
(license license:gpl3+)))
+
+(define-public emacs-validate
+ (package
+ (name "emacs-validate")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Malabarba/validate.el"
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "125mbd111f1h1baw0z3fzm48y1bvaigljyzvvnqgrn0shxbj0khg"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Malabarba/validate.el")
+ (synopsis "Emacs library for scheme validation")
+ (description "This Emacs library provides two functions that perform
+schema validation.")
+ (license license:gpl3+)))