summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zig.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index 853b5766c2..c9c3ddca62 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -129,7 +129,8 @@ toolchain. Among other features it provides
;; https://github.com/ziglang/zig/issues/6485
(supported-systems %64bit-supported-systems)
;; Stage3 can take a lot of time and isn't verbose.
- (properties `((max-silent-time . 9600)))
+ (properties `((max-silent-time . 9600)
+ ,@(clang-properties "13")))
(license license:expat)))
(define-public zig-0.10
@@ -192,6 +193,8 @@ toolchain. Among other features it provides
(replace "lld" lld-15)))
(native-inputs
(modify-inputs (package-native-inputs zig-0.9)
- (replace "llvm" llvm-15)))))
+ (replace "llvm" llvm-15)))
+ (properties `((max-silent-time . 9600)
+ ,@(clang-properties "15")))))
(define-public zig zig-0.10)