summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm20
-rw-r--r--gnu/packages/bioinformatics.scm20
2 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 08d4545257..8e0182691b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3380,6 +3380,26 @@ the results is also provided. All PCA methods make use of the same data
structure (pcaRes) to provide a common interface to the PCA results.")
(license license:gpl3+)))
+(define-public r-protgenerics
+ (package
+ (name "r-protgenerics")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ProtGenerics" version))
+ (sha256
+ (base32
+ "0yihxphgkshvfv1sn67wc4zvr2zlzws2j7ki3zabm6vyfkfdkfiz"))))
+ (properties `((upstream-name . "ProtGenerics")))
+ (build-system r-build-system)
+ (home-page "https://github.com/lgatto/ProtGenerics")
+ (synopsis "S4 generic functions for proteomics infrastructure")
+ (description
+ "This package provides S4 generic functions needed by Bioconductor
+proteomics packages.")
+ (license license:artistic2.0)))
+
(define-public r-rbgl
(package
(name "r-rbgl")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b356a76681..ca0952895c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9027,26 +9027,6 @@ for analyzing gene-level association tests in meta-analyses for binary
trait.")
(license license:gpl3)))
-(define-public r-protgenerics
- (package
- (name "r-protgenerics")
- (version "1.22.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "ProtGenerics" version))
- (sha256
- (base32
- "0yihxphgkshvfv1sn67wc4zvr2zlzws2j7ki3zabm6vyfkfdkfiz"))))
- (properties `((upstream-name . "ProtGenerics")))
- (build-system r-build-system)
- (home-page "https://github.com/lgatto/ProtGenerics")
- (synopsis "S4 generic functions for proteomics infrastructure")
- (description
- "This package provides S4 generic functions needed by Bioconductor
-proteomics packages.")
- (license license:artistic2.0)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))