summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f4903b8538..270d665251 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19786,6 +19786,16 @@ services.")
(base32
"1nii1sz5jq75ilf18bjnr11l9rz1lvdmyk66bxl7q90qan85yhjj"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'dont-install-defunct-egginfo
+ (lambda _
+ ;; When a ".git" directory is missing, the setup.py
+ ;; script invokes setuptools.setup twice, once with
+ ;; "0" as the version. Prevent that.
+ (substitute* "setup.py"
+ (("if not isdir\\('\\.git'\\):")
+ "if False:")))))))
(native-inputs
(list python-pytest))
(propagated-inputs