summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1866f9c920..15f1a80fed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2083,13 +2083,13 @@ conventions and aliases in the same expression.")
(define-public python-wand
(package
(name "python-wand")
- (version "0.6.10")
+ (version "0.6.11")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Wand" version))
(sha256
- (base32 "0mywzs235skwq670c80achrd34kangwy24793k1nij3651zllgrp"))))
+ (base32 "15d9kxyc7qvknx0kv27m2jamnmisckyf89i7wlqykwgqm46p0qdn"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2097,7 +2097,11 @@ conventions and aliases in the same expression.")
(add-after 'unpack 'find-magickwand
(lambda* (#:key inputs #:allow-other-keys)
(setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
- (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16"))))))
+ (setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
+ (replace 'check
+ (lambda _
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
(list python-pytest))
(inputs