summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 503e0f6e63..bea81e16b9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -766,6 +766,35 @@ UTF-8.")
(description "Bytes related utility functions.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-bytecount-0.5
+ (package
+ (name "rust-bytecount")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bytecount" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z6a280kiy4kg5v3qw97pbyvwycr17fsm41804i8zpq7nmads3xy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-packed-simd" ,rust-packed-simd-0.3))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.2)
+ ("rust-quickcheck" ,rust-quickcheck-0.8)
+ ("rust-rand" ,rust-rand-0.4))))
+ (home-page "https://github.com/llogiq/bytecount")
+ (synopsis "Count occurrences of a given byte")
+ (description
+ "Count occurrences of a given byte, or the number of UTF-8 code points,
+in a byte slice, fast.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-byteorder-1.3
(package
(name "rust-byteorder")