summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 28c2ae9b13..1aa5342e8d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5412,6 +5412,17 @@ Plus all the standard features of requests:
@end itemize")
(license license:bsd-3)))
+;;; Variant used to break a cycle with python-uvicorn.
+(define-public python-httpx-bootstrap
+ (hidden-package
+ (package/inherit python-httpx
+ (name "python-httpx-bootstrap")
+ (arguments (list #:tests? #f))
+ (native-inputs '())
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs python-httpx)
+ (replace "python-httpcore" python-httpcore-bootstrap))))))
+
(define-public python-wsgiprox
(package
(name "python-wsgiprox")