summaryrefslogtreecommitdiff
path: root/private/komodo/komodo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'private/komodo/komodo.scm')
-rw-r--r--private/komodo/komodo.scm29
1 files changed, 25 insertions, 4 deletions
diff --git a/private/komodo/komodo.scm b/private/komodo/komodo.scm
index 0262ebbce2..709a2f71d9 100644
--- a/private/komodo/komodo.scm
+++ b/private/komodo/komodo.scm
@@ -1,5 +1,6 @@
(define-module (komodo)
#:use-module (cpprestsdk)
+ #:use-module (gnu packages)
#:use-module (gnu packages boost)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
@@ -43,7 +44,8 @@
"sodiumConfig.cmake.in"))))))))
(define-public komodo-wallet
- (let ((version "0.7.0-beta"))
+ (let ((build-path-expected "../build/_deps/expected-src")
+ (version "0.7.0-beta"))
(package
(name "komodo-wallet")
(version version)
@@ -71,14 +73,33 @@
(substitute*
"CMakeLists.txt"
(("include\\(vcpkg_prerequisites\\)")
- "file(MAKE_DIRECTORY \"../build/_deps/expected-src\")")))))
+ (string-append
+ "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
+ "file(COPY "
+ #+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/TartanLlama/expected")
+ (commit "v1.1.0")
+ (recursive? #t)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+ (file-name (git-file-name "libexpected" "1.1.0"))
+ (patches
+ (search-patches "libexpected-use-provided-catch2.patch")))
+ "/ " " DESTINATION " #+ build-path-expected
+ " FILES_MATCHING PATTERN \"*\""
+ " FOLLOW_SYMLINK_CHAIN)\n"))))))
#:configure-flags
#~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
(native-inputs
(list
boost cpprestsdk date doctest entt fmt git libsodium-komodo nlohmann-json
- openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5 range-v3
- spdlog zlib))
+ openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
+ range-v3 spdlog zlib))
(synopsis "Komodo Wallet Desktop GUI")
(description
(string-append