summaryrefslogtreecommitdiff
path: root/private/komodo
diff options
context:
space:
mode:
Diffstat (limited to 'private/komodo')
-rw-r--r--private/komodo/komodo.scm177
1 files changed, 89 insertions, 88 deletions
diff --git a/private/komodo/komodo.scm b/private/komodo/komodo.scm
index 285b53a5b1..b9b72a59f6 100644
--- a/private/komodo/komodo.scm
+++ b/private/komodo/komodo.scm
@@ -48,91 +48,92 @@
(build-path-jl777-coins "../build/_deps/jl777-coins-src")
(build-path-mm2 "../build/_deps/mm2-src")
(version "0.7.0-beta"))
- (let ((komodo-wallet-arguments
- (list
- #:phases
- #~ (modify-phases
- %standard-phases
- (add-after
- 'unpack
- 'delete-vcpkg
- (lambda _
- (substitute*
- "CMakeLists.txt"
- (("include\\(vcpkg_prerequisites\\)")
- (string-append
- "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
- "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
- "file(COPY "
- #+ (origin
- (uri
- (git-reference
- (url
- "https://github.com/TartanLlama/expected")
- (commit "v1.1.0")
- (recursive? #t)))
- (method git-fetch)
- (hash
- (content-hash
- "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
- (file-name (git-file-name "libexpected" "1.1.0"))
- (patches
- (search-patches "libexpected-use-provided-catch2.patch")))
- "/ " " DESTINATION " #+ build-path-expected
- " NO_SOURCE_PERMISSIONS"
- " FOLLOW_SYMLINK_CHAIN)\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
- " DESTINATION " #+ build-path-jl777-coins " )\n"
- "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
- "DESTINATION " #+ build-path-jl777-coins ")\n"
- "file(ARCHIVE_EXTRACT INPUT "
- #+ (origin
- (uri
- "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
- (method url-fetch)
- (hash
- (content-hash
- "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
- " DESTINATION " #+ build-path-mm2 " )\n"))))))
- #:configure-flags
- #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
- (komodo-wallet-description
- (string-append
- "Komodo Wallet is a secure wallet and non-custodial "
- "decentralized exchange rolled into one application. Store "
- "your coind, trade peer-to-peer with minimal fees and never "
- "give up control over your digital assets."))
- (komodo-wallet-native-inputs
- (list
- boost cpprestsdk date doctest entt fmt git libsodium-komodo nlohmann-json
- openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
- range-v3 spdlog zlib))
- (komodo-wallet-origin
- (origin
- (uri
- (git-reference
- (url
- "https://github.com/KomodoPlatform/komodo-wallet-desktop")
- (commit version)))
- (method git-fetch)
- (hash
- (content-hash
- "0pfkgas0xkixf99zqzyri80ksp89b7dw7hbcgpp60ni2cnchxk2n")))))
- (package
- (name "komodo-wallet")
- (version version)
- (source komodo-wallet-origin)
- (build-system qt-build-system)
- (arguments komodo-wallet-arguments)
- (native-inputs komodo-wallet-native-inputs)
- (synopsis "Komodo Wallet Desktop GUI")
- (description komodo-wallet-description)
- (license license:gpl2)
- (home-page "https://atomicdex.io/")))))
+ (let ()
+ (let ((komodo-wallet-arguments
+ (list
+ #:phases
+ #~ (modify-phases
+ %standard-phases
+ (add-after
+ 'unpack
+ 'delete-vcpkg
+ (lambda _
+ (substitute*
+ "CMakeLists.txt"
+ (("include\\(vcpkg_prerequisites\\)")
+ (string-append
+ "\nfile(MAKE_DIRECTORY \"" #+ build-path-expected "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-jl777-coins "\")\n"
+ "file(MAKE_DIRECTORY \"" #+ build-path-mm2 "\")\n"
+ "file(COPY "
+ #+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/TartanLlama/expected")
+ (commit "v1.1.0")
+ (recursive? #t)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+ (file-name (git-file-name "libexpected" "1.1.0"))
+ (patches
+ (search-patches "libexpected-use-provided-catch2.patch")))
+ "/ " " DESTINATION " #+ build-path-expected
+ " NO_SOURCE_PERMISSIONS"
+ " FOLLOW_SYMLINK_CHAIN)\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri "https://github.com/KomodoPlatform/coins/archive/master.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1icbd6f8nridzc93vz7hsr5dnkrf328zfsw6rrzifc7nvsr559w8")))
+ " DESTINATION " #+ build-path-jl777-coins " )\n"
+ "file(COPY " #+ build-path-jl777-coins "/coins-master/ "
+ "DESTINATION " #+ build-path-jl777-coins ")\n"
+ "file(ARCHIVE_EXTRACT INPUT "
+ #+ (origin
+ (uri
+ "https://sdk.devbuilds.komodo.earth/main/mm2_b0fd99e-linux-x86-64.zip")
+ (method url-fetch)
+ (hash
+ (content-hash
+ "1bn2sjcrp9ih44h3p96prnwg74aids7fgzcnlv3c68nan6y2lysi")))
+ " DESTINATION " #+ build-path-mm2 " )\n"))))))
+ #:configure-flags
+ #~ (list "-Wno-dev" "-DFETCHCONTENT_FULLY_DISCONNECTED=ON")))
+ (komodo-wallet-description
+ (string-append
+ "Komodo Wallet is a secure wallet and non-custodial "
+ "decentralized exchange rolled into one application. Store "
+ "your coind, trade peer-to-peer with minimal fees and never "
+ "give up control over your digital assets."))
+ (komodo-wallet-native-inputs
+ (list
+ boost cpprestsdk date doctest entt fmt git libsodium-komodo nlohmann-json
+ openssl qtcharts qtdeclarative-5 qttools-5 qtsvg-5 qtwebengine-5
+ range-v3 spdlog zlib))
+ (komodo-wallet-origin
+ (origin
+ (uri
+ (git-reference
+ (url
+ "https://github.com/KomodoPlatform/komodo-wallet-desktop")
+ (commit version)))
+ (method git-fetch)
+ (hash
+ (content-hash
+ "0pfkgas0xkixf99zqzyri80ksp89b7dw7hbcgpp60ni2cnchxk2n")))))
+ (package
+ (name "komodo-wallet")
+ (version version)
+ (source komodo-wallet-origin)
+ (build-system qt-build-system)
+ (arguments komodo-wallet-arguments)
+ (native-inputs komodo-wallet-native-inputs)
+ (synopsis "Komodo Wallet Desktop GUI")
+ (description komodo-wallet-description)
+ (license license:gpl2)
+ (home-page "https://atomicdex.io/"))))))