From 62a3bbfdfef42b8aa0b8a04bbf62c9f845903da9 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Mon, 6 Apr 2020 14:58:19 +0200
Subject: gnu: hurd: Install the UTF-8 motd.

* gnu/packages/hurd.scm (hurd)[arguments]: Add 'install-goodies' phase.
---
 gnu/packages/hurd.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 45e1b21a77..e5ad8e4f73 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -409,6 +409,16 @@ fsysopts / --writable\n"))
                            (patch-shebang file path))
                          (find-files (string-append out "/libexec")))
                #t)))
+         (add-after 'install 'install-goodies
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Install additional goodies.
+             ;; TODO: Build & install *.msgids for rpctrace.
+             (let ((out (assoc-ref outputs "out")))
+               ;; Install the fancy UTF-8 motd.
+               (mkdir-p (string-append out "/etc"))
+               (copy-file "console/motd.UTF8"
+                          (string-append out "/etc/motd"))
+               #t)))
          (add-after 'install 'install-rc-file
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
-- 
cgit v1.2.3