From 14ea50518d26060b12149078371b4a50e0dee938 Mon Sep 17 00:00:00 2001
From: Troy Figiel <troy@troyfigiel.com>
Date: Sun, 11 Feb 2024 01:24:12 +0100
Subject: gnu: go-github-com-charmbracelet-bubbletea: Remove examples.

* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): Remove
examples and tutorials.
[arguments] <#:phases>: Add remove-examples phase.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: Ic4ed211ae0fa0849770264ccc950a73d55cd70c4
---
 gnu/packages/golang.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 50a73a1ae3..a91dca5206 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9707,7 +9707,14 @@ string.")
          "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/charmbracelet/bubbletea"))
+     (list
+      #:import-path "github.com/charmbracelet/bubbletea"
+      #:phases #~(modify-phases %standard-phases
+                   (add-after 'unpack 'remove-examples
+                     (lambda* (#:key import-path #:allow-other-keys)
+                       (with-directory-excursion (string-append "src/" import-path)
+                         (for-each delete-file-recursively
+                                   '("examples" "tutorials"))))))))
     (propagated-inputs
      `(("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
        ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)
-- 
cgit v1.2.3