From 86e782e2b6838fe425074c2b4758633ceefb639a Mon Sep 17 00:00:00 2001
From: Brandon Lucas
Date: Sun, 16 Jan 2022 10:50:33 +0000
Subject: gnu: Add emacs-fennel-mode.
* gnu/packages/emacs-xyz.scm (emacs-fennel-mode): New variable.
Signed-off-by: Nicolas Goaziou
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
(limited to 'gnu')
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b317d4dc58..5c3af473e2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -106,6 +106,7 @@
;;; Copyright © 2021 la snesne
;;; Copyright © 2021 Brian Kubisiak
;;; Copyright © 2021, 2022 Taiju HIGASHI
+;;; Copyright © 2022 Brandon Lucas
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29748,3 +29749,23 @@ Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
wraps GNU Global calls and integration to editor using this API with
project.el and xref.el.")
(license license:gpl3+))))
+
+(define-public emacs-fennel-mode
+ (package
+ (name "emacs-fennel-mode")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/technomancy/fennel-mode")
+ (commit version)))
+ (sha256
+ (base32 "0dwas3ivhxdyw6njkcadc8c17cirq325cmby04qls8zkmrvlil1w"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/technomancy/fennel-mode")
+ (synopsis "Emacs major-mode for editing Fennel code")
+ (description
+ "Fennel mode provides font-lock, indentation, navigation, and REPL for
+ Fennel code within Emacs.")
+ (license license:gpl3+)))
--
cgit v1.2.3