Fix the check for the prebuilt helpfile when xsltproc is not available.

--- bitlbee-3.4/configure.orig	2015-03-25 18:09:10.000000000 -0400
+++ bitlbee-3.4/configure	2015-05-20 14:51:33.627975970 -0400
@@ -650,8 +650,8 @@
 
 if [ "$doc" = "1" ]; then
 	if [ ! -e doc/user-guide/help.txt ] && \
-	     ! type xmlto > /dev/null 2> /dev/null || \
-	     ! type xsltproc > /dev/null 2> /dev/null
+	     (! type xmlto > /dev/null 2> /dev/null || \
+	      ! type xsltproc > /dev/null 2> /dev/null)
 	then
 		echo
 		echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'