summaryrefslogtreecommitdiff
path: root/packages/komodo/komodo.scm
diff options
context:
space:
mode:
authorMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-24 09:11:32 +0100
committerMarek Paśnikowski <marek@marekpasnikowski.pl>2024-03-24 09:11:32 +0100
commita2ef38478bf6f18bcb30334bcb1c058c52506457 (patch)
tree8acfe1023ddcf2c5619e0df3a9b23c9642d1ea5e /packages/komodo/komodo.scm
parent4e9c98b3636775a3cfa8b7412ada5a45fcbdb8b5 (diff)
komodo: add nlohmann/json header to another header: fixes compilation error
Diffstat (limited to 'packages/komodo/komodo.scm')
-rw-r--r--packages/komodo/komodo.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/packages/komodo/komodo.scm b/packages/komodo/komodo.scm
index baead0d..477b16d 100644
--- a/packages/komodo/komodo.scm
+++ b/packages/komodo/komodo.scm
@@ -261,6 +261,11 @@
(("doom::meta")
"doom_meta")))
+(define include-nlohmann
+ `(substitute* "src/core/atomicdex/config/electrum.cfg.hpp"
+ (("STD")
+ "STD\n#include <nlohmann/json.hpp>")))
+
(define remove-unity
`(substitute* "src/CMakeLists.txt"
(("UNITY_BUILD ON")
@@ -283,7 +288,8 @@
,replace-vcpkg
,fix-date
,fix-doom-meta
- ,remove-unity))
+ ,remove-unity
+ ,include-nlohmann))
(define entt-komodo-content-hash-get
(content-hash (base32 entt-komodo-hash)))