summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-25 13:12:35 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-28 10:39:00 +0200
commit058ce073da2c3c7de7449f7296d262178e3a929f (patch)
tree5d48250748a68fc00a628786dbe86b0628c9e37b
parentffa3355458b8938691735996c802549976861b66 (diff)
gnu: Add r-ggstatsplot.
* gnu/packages/cran.scm (r-ggstatsplot): New variable.
-rw-r--r--gnu/packages/cran.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2858aebc5a..7673f0ffbb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -799,6 +799,49 @@ text annotations.")
"Ggfittext is a ggplot2 extension for fitting text into boxes.")
(license license:gpl2)))
+(define-public r-ggstatsplot
+ (package
+ (name "r-ggstatsplot")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggstatsplot" version))
+ (sha256
+ (base32
+ "17jxvzr4dlvsakrsvblxngg60jxh0c1a0i8phqqg63nbf79ng2lk"))))
+ (properties `((upstream-name . "ggstatsplot")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-correlation
+ r-datawizard
+ r-dplyr
+ r-ggcorrplot
+ r-ggplot2
+ r-ggrepel
+ r-ggside
+ r-ggsignif
+ r-glue
+ r-insight
+ r-paletteer
+ r-parameters
+ r-patchwork
+ r-performance
+ r-purrr
+ r-rlang
+ r-statsexpressions
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://indrajeetpatil.github.io/ggstatsplot/")
+ (synopsis "Based plots with statistical details")
+ (description
+ "This package generates graphics with embedded details from statistical tests.
+Statistical tests included in the plots themselves. It provides an easier
+syntax to generate information-rich plots for statistical analysis of
+continuous or categorical data. Currently, it supports the most common
+types of statistical approaches and tests: parametric, nonparametric,
+robust, and Bayesian versions of t-test/ANOVA, correlation analyses,
+contingency table analysis, meta-analysis, and regression analyses.")
+ (license license:gpl3)))
+
(define-public r-glmpca
(package
(name "r-glmpca")