summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-09 14:14:08 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:30 -0400
commit067c4df6f3a4359b40043006975c7534411e2fce (patch)
tree70b4aa768e334c720a30ca8ebbacd8056c3ef3e5
parent2081bc48a326de4d259e703ee5c093160d94f4f8 (diff)
gnu: Add ruby-irb.
* gnu/packages/ruby.scm (ruby-irb): New variable.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f633ee1131..4d638cc3f7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -540,6 +540,27 @@ an extensible architecture with a swappable backend.")
(home-page "https://github.com/ruby/io-console")
(license license:bsd-2)))
+(define-public ruby-irb
+ (package
+ (name "ruby-irb")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "irb" version))
+ (sha256
+ (base32
+ "1h9s07n5v3z029v18924ws9vdkdc80n6llp9ccx77yg1krv2g0f3"))))
+ (build-system ruby-build-system)
+ ;; XXX: Disable the test suite, as it requires debug, which requires this
+ ;; package (dependency cycle).
+ (arguments (list #:tests? #f))
+ (propagated-inputs (list ruby-reline))
+ (synopsis "Ruby command-line tool for REPL (Read Eval Print Loop)")
+ (description "IRB is an interactive Ruby command-line tool for REPL (Read
+Eval Print Loop).")
+ (home-page "https://github.com/ruby/irb")
+ (license license:bsd-2)))
+
(define-public ruby-iruby
(package
(name "ruby-iruby")