summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:48:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:06 +0200
commit0c82291f453f48eb3123bbeb7397f9069328d631 (patch)
treedd9a8f9ad55474375f1c30eca1cb31ca22bd8005
parentba81602c2449f05dc025b24afc4311abfed78bb6 (diff)
gnu: Add texlive-tikzviolinplots.
* gnu/packages/tex.scm (texlive-tikzviolinplots): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bae8719be1..c1b5c0b507 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5284,6 +5284,28 @@ PGFPlots to a given width or height without changing the text size.")
@command{pdf2svg} to convert TikZ environments to SVG files.")
(license license:gpl3)))
+(define-public texlive-tikzviolinplots
+ (package
+ (name "texlive-tikzviolinplots")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzviolinplots/"
+ "tex/latex/tikzviolinplots/")
+ (base32
+ "1cm1pcv4x9qpsxghvxv1w212j8p37g5miqn73d5xwy0vaqhd0hhz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzviolinplots")
+ (synopsis "Draws violin plots from data")
+ (description
+ "This package enables the user to draw violin plots, calculating the
+kernel density estimation from the data and plotting the resulting curve
+inside a @code{tikzpicture} environment. It supports different kernels, and
+allows the user to either set the bandwidth value for each plot or use
+a default value.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")