summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:09 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:07:28 +0100
commit11c1621b536ee29daf8091f65f4f9d7c77a5f16d (patch)
tree533a67de30a6acb3e87a1cbe166780b9a1bcaf6f
parentbe311533902900f16ff58cc18061ca4522441033 (diff)
gnu: Add ocaml5.0-base.
* gnu/packages/ocaml.scm (ocaml5.0-base): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4a45f5f73b..430e6a341b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5487,7 +5487,8 @@ functionality for parsing and pretty-printing s-expressions.")
(build-system dune-build-system)
(propagated-inputs
(list ocaml-sexplib0))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-base))))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-base))
+ (ocaml5.0-variant . ,(delay ocaml5.0-base))))
(synopsis
"Full standard library replacement for OCaml")
(description
@@ -5502,6 +5503,28 @@ provided by companion libraries such as
@url{https://github.com/janestreet/stdio, ocaml-stdio}.")
(license license:expat)))
+(define-public ocaml5.0-base
+ ;; This version contains fixes for OCaml 5.0
+ ;; (see https://github.com/ocaml/opam-repository/pull/21851)
+ (let ((commit "423dbad212f55506767d758b1ceb2d6e0ee8e7f5")
+ (revision "0"))
+ (package-with-ocaml5.0
+ (package
+ (inherit ocaml-base)
+ (name "ocaml-base")
+ (version (git-version "0.15.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kit-ty-kate/base")
+ (commit commit)))
+ (file-name (git-file-name "ocaml5.0-base" version))
+ (sha256
+ (base32
+ "15vsiv3q53l1bzrvqgspf3lp2104s9dzw62z3nl75f53jvjvsyf6"))))
+ (properties '())))))
+
(define-public ocaml4.07-base
(package-with-ocaml4.07
(package