summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2023-03-07 04:43:01 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-07 11:18:50 +0100
commit26e9725c54df48eda8282e6716a7581a7755f8f9 (patch)
tree88413a59b1f7ce0c5e348708e1a72545a09c804d
parent79da3b19f0c9b506f58767159dd7a24d835fdce0 (diff)
gnu: Add cl-eazy-gnuplot.
* gnu/packages/lisp-xyz.scm (sbcl-eazy-gnuplot, cl-eazy-gnuplot, ecl-eazy-gnuplot): New variables. * gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/lisp-xyz.scm47
-rw-r--r--gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch14
3 files changed, 62 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 70dab40087..6c5a9ce024 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1834,6 +1834,7 @@ dist_patch_DATA = \
%D%/packages/patches/sbcl-aserve-fix-rfe12668.patch \
%D%/packages/patches/sbcl-burgled-batteries3-fix-signals.patch \
%D%/packages/patches/sbcl-clml-fix-types.patch \
+ %D%/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch \
%D%/packages/patches/sbcl-png-fix-sbcl-compatibility.patch \
%D%/packages/patches/scalapack-gcc-10-compilation.patch \
%D%/packages/patches/scheme48-tests.patch \
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8fed05b999..8c87f25a84 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10068,6 +10068,53 @@ visualization.")
(define-public cl-ana
(sbcl-package->cl-source-package sbcl-cl-ana))
+(define-public sbcl-eazy-gnuplot
+ (let ((commit "2eb900fe2557e6c066a9851c166e572c25bc0996")
+ (revision "0"))
+ (package
+ (name "sbcl-eazy-gnuplot")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/guicho271828/eazy-gnuplot")
+ (commit commit)))
+ (file-name (git-file-name "cl-eazy-gnuplot" version))
+ (sha256
+ (base32 "0mpkx1z52riahydzvqv7kk15p0pv2k7k5a7j65fg571kcxmssx8s"))
+ (patches (search-patches "sbcl-eazy-gnuplot-skip-path-check.patch"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-fiveam))
+ (inputs
+ (list gnuplot
+ sbcl-alexandria
+ sbcl-iterate
+ sbcl-trivia))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda _
+ (substitute* "src/package.lisp"
+ (("\"gnuplot\"")
+ (string-append "\"" (which "gnuplot") "\""))))))))
+ (home-page "https://github.com/guicho271828/eazy-gnuplot")
+ (synopsis "Common Lisp interface to gnuplot")
+ (description
+ "Eazy-Gnuplot is a Common Lisp interface to gnuplot which eschews CFFI,
+CLOS and structures. It communicates with @command{gnuplot} via
+@code{*standard-output*}, and users can plot data by printing to that
+stream.")
+ (license license:llgpl))))
+
+(define-public cl-eazy-gnuplot
+ (sbcl-package->cl-source-package sbcl-eazy-gnuplot))
+
+(define-public ecl-eazy-gnuplot
+ (sbcl-package->ecl-package sbcl-eazy-gnuplot))
+
(define-public sbcl-archive
(let ((commit "631271c091ed02994bec3980cb288a2cf32c7cdc")
(revision "1"))
diff --git a/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
new file mode 100644
index 0000000000..ccc9c09fb9
--- /dev/null
+++ b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
@@ -0,0 +1,14 @@
+Don't check whether gnuplot is present in $PATH, because we know it is.
+
+diff --git a/eazy-gnuplot.asd b/eazy-gnuplot.asd
+index 7b1c09b..4657cd6 100644
+--- a/eazy-gnuplot.asd
++++ b/eazy-gnuplot.asd
+@@ -37,7 +37,4 @@
+ :fill-pointer t)))
+ (setf (fill-pointer seq) (read-sequence seq stream))
+ seq)))
+- :perform (load-op :before (op c)
+- (unless (zerop (nth-value 2 (uiop:run-program "which gnuplot" :ignore-error-status t)))
+- (warn "Could not find GNUPLOT in $PATH")))
+ :in-order-to ((test-op (test-op eazy-gnuplot.test))))