summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:09:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:09:41 +0200
commit272cfdffba638e43ed11700e1b8106b8c8ef2e1c (patch)
tree6e2f9a3a92e7d9c01d0242712d9ab2ce28aac2aa
parent81d1db24d2eeaad09584c2212703453e5bbe3bd6 (diff)
gnu: Add texlive-uplatex.
* gnu/packages/tex.scm (texlive-uplatex): New variable.
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d96de4078a..7b331a9873 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14061,6 +14061,47 @@ analytical expansion of sin and cos.")
barcodes.")
(license license:lppl)))
+(define-public texlive-uplatex
+ (package
+ (name "texlive-uplatex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/uplatex.1"
+ "doc/man/man1/uplatex.man1.pdf"
+ "doc/uplatex/base/"
+ "source/uplatex/base/"
+ "tex/uplatex/base/"
+ "tex/uplatex/config/")
+ (base32
+ "0bzkyira30b9xdsdfxjmwzgqffl9pvckz5avm6c3r0bq6asiml9l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "uplatex" "uplatex-dev")))
+ (propagated-inputs
+ (list texlive-atbegshi
+ texlive-atveryend
+ texlive-babel
+ texlive-cm
+ texlive-everyshi
+ texlive-firstaid
+ texlive-hyphen-base
+ texlive-l3backend
+ texlive-l3kernel
+ texlive-l3packages
+ texlive-latex
+ texlive-latex-fonts
+ texlive-platex
+ texlive-tex-ini-files
+ texlive-unicode-data
+ texlive-uptex
+ texlive-uptex-fonts))
+ (home-page "https://ctan.org/pkg/uplatex")
+ (synopsis "pLaTeX2e and miscellaneous macros for upTeX")
+ (description
+ "The bundle provides pLaTeX2e macros for upTeX by Takuji Tanaka.")
+ (license license:bsd-3)))
+
(define-public texlive-uptex-base
(package
(name "texlive-uptex-base")