summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:16:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:36 +0200
commit2b6dd12aeed14538e4e84eaa6a95548202a14f0b (patch)
tree125500a186d1a5263e89ad231d3c46a2239cb14a
parentd642554212195a3d0a5db4d99ce8674e29770457 (diff)
gnu: Add texlive-latexpand.
* gnu/packages/tex.scm (texlive-latexpand): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 71ecb72138..7c1e80e9c6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2684,6 +2684,28 @@ style file.")
highlight the structure for the reader.")
(license license:gpl3)))
+(define-public texlive-latexpand
+ (package
+ (name "texlive-latexpand")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/latexpand/"
+ "scripts/latexpand/")
+ (base32
+ "0v0yn4n6v0kgxwh00ryfkrx7a4sxhkm0pbgnylvi8jfg24gz89ls")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "latexpand")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/latexpand")
+ (synopsis "Expand @code{\\input} and @code{\\include} in a LaTeX document")
+ (description
+ "Latexpand is a Perl script that simply replaces @code{\\input} and
+@code{\\include} commands with the content of the input or included file. The
+script does not deal with @code{\\includeonly} commands.")
+ (license license:bsd-3)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")