summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:33:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:18 +0200
commit2fc6ae43b5f0eb30795cdf559456398b6c5f8bf4 (patch)
tree409ebaa1f1faec5256955b5d7fe3e510ca728c5b
parenta32c0b61ce6747e6a4cf010b889aaf4e30adac71 (diff)
gnu: Add texlive-mf2pt1.
* gnu/packages/tex.scm (texlive-mf2pt1): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 34412ab2b3..626b44392e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1937,6 +1937,33 @@ Latin Modern fonts, and the distribution includes an example development of
Knuth's logo fonts.")
(license license:public-domain)))
+(define-public texlive-mf2pt1
+ (package
+ (name "texlive-mf2pt1")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/info/mf2pt1.info" "doc/support/mf2pt1/"
+ "metapost/mf2pt1/" "scripts/mf2pt1/")
+ (base32
+ "17dq4csl10j89rrxgyqjp3fjqkd9q6djgz9yi33y72w5ymjgiaik")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "mf2pt1.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/mf2pt1")
+ (synopsis "Convert stylized Metafont to PostScript Type 1")
+ (description
+ "@command{mf2pt1} is a Perl script that facilitates producing PostScript
+Type 1 fonts from a Metafont source file. It is not, as the name may imply,
+an automatic converter of arbitrary Metafont fonts to Type 1 format.
+@command{mf2pt1} imposes a number of restrictions on the Metafont input. If
+these restrictions are met, it will produce valid Type 1 output with more
+accurate control points than can be reverse-engineered by TeXtrace,
+@command{mftrace}, and other programs which convert bitmaps to outline
+fonts.")
+ (license license:lppl1.3c)))
+
(define-public texlive-mfirstuc
(package
(name "texlive-mfirstuc")