summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:14:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:36 +0200
commit30b7a6393eec55eb9453f4cbe60b67c629a86339 (patch)
treea6446ac99b85e81738f6478a9ab0dbcbc9262458
parent86556e6bb9fca81d26036cc5652e482678bee875 (diff)
gnu: Add texlive-showkerning.
* gnu/packages/tex.scm (texlive-showkerning): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c831b3b9d1..b044020353 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13859,6 +13859,28 @@ size adjusts to the font size. By option the markers can be placed behind or
in front of the glyphs. The package requires LuaLaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-showkerning
+ (package
+ (name "texlive-showkerning")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/showkerning/"
+ "tex/lualatex/showkerning/")
+ (base32
+ "0kd20scd9mv7zmsfz9wy321j07fwkll94cbfpqllzn0jk80qgxgm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/showkerning")
+ (synopsis "Showing kerns in a document")
+ (description
+ "The package displays all kerning values in the form of colored bars
+directly at the respective position in the document. Positive values are
+displayed in green, negative values in red. The width of the bars corresponds
+exactly to the respective kerning value. By option the bars can be placed
+behind or in front of the glyphs. The package requires LuaLaTeX.")
+ (license license:lppl1.3c)))
+
(define-public texlive-standalone
(package
(name "texlive-standalone")