summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-22 17:56:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:02 +0300
commit35af6cd4bf1acbca49bec89844645e6f4e77e0fb (patch)
treea51062df440dcd3b3094c6e98aae6331c826d41c
parentfa1ec3bc3426cdaa6c9c1e323ff4b3d01706e631 (diff)
gnu: Add rust-fehler-1.
* gnu/packages/crates-io.scm (rust-fehler-1): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 93f027a6f1..ecd433ad8d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22641,6 +22641,26 @@ Atom, RSS 2.0, RSS 1.0, RSS 0.x and JSON Feed")
;; No copyright headers in the source code. LICENSE indicates gpl3.
(license license:gpl3)))
+(define-public rust-fehler-1
+ (package
+ (name "rust-fehler")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "fehler" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0d9nk0nimhrqhlwsm42kmg6bwhfqscnfddj70xawsa50kgj9ywnm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-fehler-macros" ,rust-fehler-macros-1))))
+ (home-page "https://github.com/withoutboats/fehler")
+ (synopsis "Library for error-handling syntax in Rust")
+ (description
+ "This package provides a library for error-handling syntax in Rust.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-fehler-macros-1
(package
(name "rust-fehler-macros")