summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 01:53:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:33 -0400
commit3b366fd11899b2b9b7f11d60266b1ed23ad66ec5 (patch)
treef40ab37da8ee0bac0538b52ac8e6047783a11286
parent021e9d8102974f44d44dc03df275242d6cc48000 (diff)
gnu: gnome-disk-utility: Update to 42.0.
* gnu/packages/gnome.scm (gnome-disk-utility): Update to 42.0. [native-inputs]: Delete labels. Replace intltool with gettext-minimal.
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 115ca351d2..5742651594 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2230,7 +2230,7 @@ The gnome-about program helps find which version of GNOME is installed.")
(define-public gnome-disk-utility
(package
(name "gnome-disk-utility")
- (version "40.2")
+ (version "42.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -2238,7 +2238,7 @@ The gnome-about program helps find which version of GNOME is installed.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1rr1ypb89p51b6428yqvczmpmylwjfnhnkgx78hzm3vxm3m15lff"))))
+ "02q906gn420xbf1f0apazryzqfv5b1ammz1vrci66hk79m2n8r8v"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dlogind=libelogind")
@@ -2248,16 +2248,15 @@ The gnome-about program helps find which version of GNOME is installed.")
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ (("gtk-update-icon-cache") "true")))))))
(native-inputs
- `(("glib:bin" ,glib "bin")
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("docbook-xml" ,docbook-xml)
- ("docbook-xsl" ,docbook-xsl)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)))
+ (list docbook-xml
+ docbook-xsl
+ `(,glib "bin")
+ gettext-minimal
+ pkg-config
+ libxml2
+ libxslt))
(inputs
(list elogind
glib