summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-19 16:35:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:42 +0200
commit4104e8ae7212e3f763da0f98cb907966ef1c6e75 (patch)
tree3e377c2b5529d62eb14a16b6a3edfe3101c8706a
parent80e2694ff9d68a6553caab0e00fe57c345144eaf (diff)
gnu: texlive-tipa: Fix build.
* gnu/packages/tex.scm (texlive-tipa)[arguments]<#:modules, #:phases>: Remove them.
-rw-r--r--gnu/packages/tex.scm61
1 files changed, 0 insertions, 61 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c1d6d8a001..ec1b1dba18 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5044,67 +5044,6 @@ It includes little more than the required set of LaTeX packages.")))
"11gi7yhq2lnfgvqa29i0sidi5mwkzpja5ggdcpvqwv4xljf4vpvh")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments
- (list
- #:modules
- '((guix build texlive-build-system)
- (guix build utils)
- (ice-9 regex)
- (srfi srfi-1)
- (srfi srfi-26))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'generate-fonts-metrics
- (lambda _
- (let ((mf #$(this-package-native-input "texlive-metafont"))
- (cm #$(this-package-native-input "texlive-cm"))
- (fonts-directories
- (delete-duplicates
- (map dirname
- (find-files "." "[0-9]+\\.mf$"))))
- (root (getcwd)))
- (mkdir-p "build")
- ;; Tell mf where to find mf.base.
- (setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
- (for-each
- (lambda (directory)
- ;; Tell mf where to look for source files.
- (setenv "MFINPUTS"
- (string-append
- (getcwd) "/" directory ":"
- mf "/share/texmf-dist/metafont/base:"
- cm "/share/texmf-dist/fonts/source/public/cm"))
- ;; Build font metrics (tfm).
- (with-directory-excursion directory
- (for-each (lambda (font)
- (format #t "building font ~a\n" font)
- (invoke "mf" "-progname=mf"
- (string-append "-output-directory="
- root "/build")
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input "
- (basename font ".mf"))))
- ;; "tipasym[1-4].mf are files to be included in
- ;; other ".mf" files and should not be compiled
- ;; by themselves.
- (filter
- (negate
- (cut string-match "tipasym[0-9]\\.mf$" <>))
- (find-files "." "[0-9]+\\.mf$"))))
- ;; Install font metrics at the appropriate location.
- (let ((destination
- ;; fonts/source/xxx/yyy/... -> fonts/tfm/xxx/yyy/...
- (string-append "fonts/tfm"
- (string-drop
- directory
- (string-length "fonts/source")))))
- (format #t "moving font metrics in ~a\n" destination)
- (for-each (cut install-file <> destination)
- (find-files "build/" "\\.tfm$"))))
- fonts-directories)))))))
(native-inputs
(list texlive-cm texlive-metafont))
(home-page "https://ctan.org/pkg/tipa")