summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:00:41 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:32 +0100
commit47532ebc1e9fd00fa101b8a7f76f318daf7d46b4 (patch)
tree78544036ec23c81a6336aa942e8d6e3cd2f45fa7
parent3d74d84235038a8329a734918c3dd0093c4935ab (diff)
gnu: Remove ocaml4.07-ppx-bin-prot.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-bin-prot): Remove variable. (ocaml-ppx-bin-prot)[properties]: Remove variant. Change-Id: I132d19d38cbb40c72afaa86a758ca0d4267fe645
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 1 insertions, 25 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ae549473f7..631b7e2bf0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7660,37 +7660,13 @@ verification tool.")
`(#:tests? #f))
(propagated-inputs
(list ocaml-base ocaml-bin-prot ocaml-ppx-here ocaml-ppxlib))
- (properties `((upstream-name . "ppx_bin_prot")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-bin-prot))))
+ (properties `((upstream-name . "ppx_bin_prot")))
(home-page "https://github.com/janestreet/ppx_bin_prot")
(synopsis "Generation of bin_prot readers and writers from types")
(description "Generation of binary serialization and deserialization
functions from type definitions.")
(license license:expat)))
-(define-public ocaml4.07-ppx-bin-prot
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-bin-prot)
- (version "0.11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/janestreet/ppx_bin_prot")
- (commit (string-append "v" version))))
- (file-name (git-file-name "ocaml4.07-ppx-bin-prot" version))
- (sha256
- (base32
- "1h60i75bzvhna1axyn662gyrzhh441l79vl142d235i5x31dmnkz"))))
- (propagated-inputs
- (list ocaml-base
- ocaml-bin-prot
- ocaml-ppx-here
- ocaml-migrate-parsetree
- ocaml-ppxlib))
- (properties '())
- (license license:asl2.0))))
-
(define-public ocaml-ppx-ignore-instrumentation
(package
(name "ocaml-ppx-ignore-instrumentation")